码迷,mamicode.com
首页 > 其他好文 > 详细

1703

时间:2014-10-22 23:27:56      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   os   ar   for   strong   

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32225   Accepted: 9947

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
题目大意:N 表示共有 N 个帮派;下面有 M 条个询问
有两个帮派,现在告诉你一些互相敌对的点对,然后让你判断某两个点之间的关系首先判两个点关系是否确定;
只要两个点在一个集合里就可以了,直接用并查集然后判断同一个集合的关系:想了很久,发现只要转换到根,看看两个点和根的关系就可以了。
只要在结点间加上个权,1表示敌对,0相反。路径压缩和合并集合的时候考虑下权做下变换就可以了。加了个秩快了一点。
AC代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
// 0 代表木有关系,1代表同类,2代表不同类
const int N = 1e5+10;
int m;
int f[N],c[N];
int init()
{
    for(int i=0; i<=m; i++)
    {
        f[i] = i;
        c[i] = 0;
    }
}
int xfind(int x)
{
    if(f[x] == x)
       return x;
       int t = f[x];
       f[x] =xfind(f[x]);
       c[x] = (c[x]+c[t])%2;
       return f[x];
}
int solve(char ch,int x,int y )
{
    int fx = xfind(x);
    int fy = xfind(y);
    if(fx != fy)
    {
        if(ch == A) return 0; //返回值
        f[fx] =fy;
        if((c[x]+c[y])%2 ==0)
            c[fx] = 1;
    }
    else
    {
        if(ch == A)
           {
               if(c[x] != c[y]) return 1;
                if(c[x] == c[y]) return 2;
           }
    }
    if(ch == D) return 3;
}
int main( )
{
    int T,n,x,y;
    char s;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&m,&n);
        init();
        for(int i=0; i<n; i++)
        {
            scanf(" %c %d %d",&s,&x,&y);
            int flag  = solve(s,x,y);
            if(flag == 0) printf("Not sure yet.\n");
            else if(flag == 1) printf("In different gangs.\n");
            else if(flag == 2) printf("In the same gang.\n");
        }
    }
    return 0;
}

 

1703

标签:des   style   blog   color   io   os   ar   for   strong   

原文地址:http://www.cnblogs.com/lovychen/p/4044446.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!