码迷,mamicode.com
首页 > 其他好文 > 详细

迷宫问题-poj3984-bfs

时间:2019-07-18 10:55:50      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:int   path   表示   print   路径   output   pair   str   lang   

定义一个二维数组: 


int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
typedef pair<int,int>P;
pair<int,int>path[5][5];//记录每个位置的前一个位置,如path[1][0]的前一个位置是path[0][0];
int dir[4][2]={{-1,0},{0,1},{0,-1},{1,0}};//方向数组
int mp[5][5];
bool vis[5][5];//记录该位置是否已经访问过
void bfs()
{
    queue<P>q;
    q.push(P(0,0));
    while(!q.empty()){
        P tmp=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            int xx=tmp.first+dir[i][0],yy=tmp.second+dir[i][1];
            if(0<=xx&&xx<5&&0<=yy&&yy<5&&mp[xx][yy]==0&&!vis[xx][yy]){
                vis[xx][yy]=true;
                path[xx][yy].first=tmp.first;//记录满足条件的(xx,yy)节点的上一个位置为(tmp.first,tmp.second)
                path[xx][yy].second=tmp.second;
                q.push(P(xx,yy));
            }
        }
    }
}

void output(int x,int y)//递归输出路径
{
    if(x==0&&y==0){
        printf("(%d, %d)\n",x,y);
        return;
    }
    output(path[x][y].first,path[x][y].second);
    printf("(%d, %d)\n",x,y);
}
int main()
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<5;i++){
        for(int j=0;j<5;j++){
            scanf("%d",&mp[i][j]);
        }
    }
    bfs();
    output(4,4);
    return 0;
}

迷宫问题-poj3984-bfs

标签:int   path   表示   print   路径   output   pair   str   lang   

原文地址:https://www.cnblogs.com/LJHAHA/p/11205697.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!