码迷,mamicode.com
首页 > 其他好文 > 详细

[kuangbin带你飞]专题四 最短路练习 I - Arbitrage(判断负环)

时间:2019-07-20 23:32:38      阅读:99      评论:0      收藏:0      [点我收藏+]

标签:ext   des   include   NPU   within   for   eth   next   之间   

I - Arbitrage

题目链接:https://vjudge.net/contest/66569#problem/I

题目:

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

题意:给你n种货币,和m种货币转换关系还有之间的单位货币数,问能否经过这些关系使得原先货数增加
思路:题没有给原先货币数,故令原先货币数为1,这题不是计算路权和而是路权积,利用spfa算法即可快速判断,由于数据范围小
可直接用邻接矩阵来存图,用时79s

//
// Created by hy on 2019/7/20.
//
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <queue>
#include <map>
#include<memory.h>
using namespace std;
const int maxn=105;
#define MAX 0x3f3f3f3f
int n,m;
double road[maxn][maxn];
double d[maxn];
int book[maxn];
int rnt[maxn];
bool spfa(int s)
{
    memset(book,0,sizeof(book));
    memset(d,MAX,sizeof(d));
    memset(rnt,0,sizeof(rnt));
    queue<int>qu;
    qu.push(s);
    book[s]=1;
    d[s]=1;
    rnt[s]++;
    while(!qu.empty())
    {
        int now=qu.front();
        qu.pop();
        book[now]=0;
        for(int i=1;i<=n;i++)
        {
            if(d[i]<d[now]*road[now][i])
            {
                d[i]=d[now]*road[now][i];
                if(!book[i])
                {
                    qu.push(i);
                    book[i]=1;
                    rnt[i]++;
                    if(rnt[i]>n-1)
                        return true;
                }
            }
        }
    }
    return false;
}
int main() {


    int res=0;
    while (~scanf("%d", &n)) {
        if(n==0)
            break;
        string str;
        map<string, int> mp;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                if(i==j)
                    road[i][j]=0;
                else
                    road[i][j]=MAX;
            }
        }
        for (int i = 1; i <= n; i++) {
            cin >> str;
            mp[str] = i;

        }
        string str1, str2;
        double num;
        scanf("%d",&m);
        for (int i = 1; i <= m; i++) {
            cin >> str1 >> num >> str2;
            road[mp[str1]][mp[str2]] = num;
        }
        res++;
        if (spfa(1))
            printf("Case %d: Yes\n",res);
        else
            printf("Case %d: No\n",res);

    }
    return 0;
}

 



[kuangbin带你飞]专题四 最短路练习 I - Arbitrage(判断负环)

标签:ext   des   include   NPU   within   for   eth   next   之间   

原文地址:https://www.cnblogs.com/Vampire6/p/11219628.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!