码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1013 Battle Over Cities (25 分)(图的遍历,统计强连通分量个数,bfs,一遍就ac啦)

时间:2019-08-01 22:51:12      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:强连通分量   相关   you   swa   view   城市   clear   邻接   line   

1013 Battle Over Cities (25 分)
 

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city?1??-city?2?? and city?1??-city?3??. Then if city?1?? is occupied by the enemy, we must have 1 highway repaired, that is the highway city?2??-city?3??.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意:

给出n个城市,城市间有m条路,k个要检查的城市
假如这k个城市被攻占,所有相关的路线全部瘫痪,要使其他城市保持连通,至少需要修缮多少条路

思路:

1.其实这是考察图的问题,删除图的一个节点,是其他节点成为连通图,至少需要添加多少条线

2.添加最少的路线,就是连通分量数-1(例:n个互相独立的连通分量组成一个连通图,只需要连n-1条线就可以)
3.这道题最重要就是求除去图的一个节点后 剩余的连通分量的数目
4.利用邻接矩阵a存储路线,用inq数组表示城市是否被遍历过

5.遍历每一个需要考虑的城市u,去掉与u相连的边,然后用bfs数有几个连通的块(类似于几个水洼)

#include<bits/stdc++.h>
using namespace std;
int N,M,K;
int is_con[1005][1005];
vector<int>a[1005];
int inq[1005];//用于bfs的标记 
queue<int>q;
void clear(queue<int>& q) {//清空队列的快捷操作 
    queue<int> empty;
    swap(empty, q);
}
int bfs(int p)//数数有几个强连通分量 
{
    memset(inq,0,sizeof(inq));
    int ans=0;
    for(int i=1;i<=N;i++)//遍历每个城市 
    {
        if(i!=p && inq[i]==0)//该城市没被标记过 
        {
            ans++;
            clear(q);
            q.push(i);inq[i]=1; 
            while(!q.empty())
            {
                int x=q.front();
                q.pop();
                //遍历与x相连的点放进队列并标记
                for(int j=0;j<a[x].size();j++)
                {
                    int y = a[x].at(j);
                    if(y!=p && is_con[x][y]!=0 && inq[y]!=1) //不是p,连通的,不在队列中 
                    {
                        q.push(y);inq[y]=1;//放入队列并标记 
                    }
                 } 
            }        
        }
    }
    return ans;
}
int main()
{
    cin>>N>>M>>K;
    memset(is_con,0,sizeof(is_con));
    for(int i=1;i<=N;i++)
    {
        a[i].clear();
    }    
    for(int i=1;i<=M;i++)
    {
        int u,v;
        cin>>u>>v;
        is_con[u][v]=is_con[v][u]=1;
        a[u].push_back(v);
        a[v].push_back(u);        
    }    
    for(int i=1;i<=K;i++)
    {
        int u;
        cin>>u;
        for(int j=0;j<a[u].size();j++)//去掉边 
        {
            int v=a[u].at(j);
            is_con[u][v]=0;
            is_con[v][u]=0;
        }
        int ans = bfs(u);
        cout<<ans-1<<endl;    
        for(int j=0;j<a[u].size();j++)//恢复去掉的边 
        {
            int v=a[u].at(j);
            is_con[u][v]=1;
            is_con[v][u]=1;
        }
    }
    return 0;
 } 

 

 

PAT 甲级 1013 Battle Over Cities (25 分)(图的遍历,统计强连通分量个数,bfs,一遍就ac啦)

标签:强连通分量   相关   you   swa   view   城市   clear   邻接   line   

原文地址:https://www.cnblogs.com/caiyishuai/p/11285799.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!