码迷,mamicode.com
首页 > 其他好文 > 详细

Mathematically Hard LightOJ-1007(欧拉定理+前缀和)

时间:2019-08-14 00:09:14      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:--   sample   注意   his   前缀   ESS   amp   har   return   

Description

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive).

The score of a number is defined as the following function.score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler‘s totient function  applied to a positive integer ø(n) is defined to be the number of positive integers less than or equal to ø(n) that

are relatively prime to ø(n).  is read "phi of n."Given the general prime factorization of 技术图片 , one can compute ø(n)using the formula

                                                                                   技术图片

在数论中,对正整数n,欧拉函数 技术图片 是小于或等于n的正整数中与n互质的数的数目,对欧拉函数打表; 

注意 :long long 需要用无符号型;

代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
typedef unsigned long long ll;
const int maxx=5001000;
ll a[maxx];
void init()
{
    for(int i=0; i<maxx; i++)
        a[i]=i;
    for(int i=2; i<maxx; i++)
    {
        if(a[i]==i)
        {
            for(int j=i; j<maxx; j+=i)
                a[j]=a[j]/i*(i-1);
        }
    }
    for(int i=2; i<maxx; i++)
        a[i]=a[i]*a[i]+a[i-1];
}
int main()
{
    init();
    int t,Case=0;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        printf("Case %d: ",++Case);
        cout<<a[m]-a[n-1]<<endl;
    }
    return 0;
}

 

Mathematically Hard LightOJ-1007(欧拉定理+前缀和)

标签:--   sample   注意   his   前缀   ESS   amp   har   return   

原文地址:https://www.cnblogs.com/dwj-2019/p/11349390.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!