码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1011 World Cup Betting 查找元素

时间:2019-08-21 11:23:16      阅读:81      评论:0      收藏:0      [点我收藏+]

标签:rod   wtl   and   from   was   计算   tle   contain   hone   

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery(彩票) provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results — ·namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds(胜算,赔率) are given as the following:
W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

题目意思:这其实是一道英文阅读题,中国体育彩票提供的一种“三赢”游戏,对于每一场比赛的三种结果赢、平局、输都有三个赔率,三场比赛作为游戏的一组,选择每一场比赛的一个赔率,那么最后所得到的利润将会是三场比赛赔率乘积的65%,再减去两块钱一次的彩票钱。

解题思路:想要获得最大的利润,找每一场赔率最高的,三场最高的分别是a、b、c,最后的计算公式就是(a*b*c*0.65-1)*2。

三个数一组,在每一组中找到最大的那一个数,保存起来,同时使用ans累乘该最大值,最后套用公式计算即可。

 

odd

[?d] [ɑd]

adj. 奇数的;古怪的;剩余的;临时的;零散的

n. 奇数;怪人;奇特的事物

odds

[?dz] [ɑdz]

n. 几率;胜算;不平等;差别

#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 0x7fffffff
using namespace std;
int main()
{
    int i,j,t,a[3];
    double d[4],maxs;
    char c[4]="WTL";
    double ans=1.0;
    for(i=0;i<3;i++)
    {
        maxs=0.0;
        for(j=0;j<3;j++)
        {
            scanf("%lf",&d[j]);
            if(d[j]>maxs)
            {
                maxs=d[j];
                t=j;
            }
        }
        ans*=maxs;
        a[i]=t;
    }
    for(i=0;i<3;i++)
    {
        printf("%c ",c[a[i]]);
    }
    ans=(ans*0.65-1)*2;
    printf("%.2lf\n",ans);
    return 0;
}

 

PAT 1011 World Cup Betting 查找元素

标签:rod   wtl   and   from   was   计算   tle   contain   hone   

原文地址:https://www.cnblogs.com/wkfvawl/p/11387388.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!