码迷,mamicode.com
首页 > 其他好文 > 详细

Poj1426 DFS模板题

时间:2019-08-25 00:54:37      阅读:100      评论:0      收藏:0      [点我收藏+]

标签:ext   个数   lsp   its   test   ref   write   std   positive   

Find The Multiple

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 51502   Accepted: 21541   Special Judge

题目链接:http://poj.org/problem?id=1426

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:输入一个数n,求只有0和1的数并且还是n的倍数的数是多少

思路:直接dfs搜,暴力搜

#include <iostream>


using namespace std;

typedef unsigned long long ULL;

int n;
bool flag = false;

void DFS(int step, ULL t) {
    if(step > 19 || flag)
    return;
    if (t % n == 0) {
        cout << t << endl;
        flag = true;
        return;
    }
    DFS(step + 1, 10 * t);
    DFS(step + 1, 10 * t + 1);
}

int main() {
    while (cin >> n) {    
        if (!n)    return 0;
        flag = false;
        DFS(1, 1);
    }
    return 0;
}

 

Poj1426 DFS模板题

标签:ext   个数   lsp   its   test   ref   write   std   positive   

原文地址:https://www.cnblogs.com/DreamInPal/p/11406485.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!