码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5083 Instruction(字符串处理)

时间:2014-10-26 11:49:22      阅读:357      评论:0      收藏:0      [点我收藏+]

标签:字符串

Problem Description
Nowadays, Jim Green has produced a kind of computer called JG. In his computer, the instruction is represented by binary code. However when we code in this computer, we use some mnemonic symbols. For example, ADD R1, R2 means to add the number in register R1 and R2, then store the result to R1. But this instruction cannot be execute directly by computer, before this instruction is executed, it must be changed to binary code which can be executed by computer. Each instruction corresponds to a 16-bit binary code. The higher 6 bits indicates the operation code, the middle 5 bits indicates the destination operator, and the lower 5 bits indicates the source operator. You can see Form 1 for more details.
15 operation code(6 bits)10bubuko.com,布布扣bubuko.com,布布扣9destination operator code(5 bits)5bubuko.com,布布扣bubuko.com,布布扣4source operator code(5 bits)0bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣Form 1bubuko.com,布布扣bubuko.com,布布扣


In JG system there are 6 instructions which are listed in Form 2.
instructionbubuko.com,布布扣ADD Ra,Rbbubuko.com,布布扣SUB Ra,Rbbubuko.com,布布扣DIV Ra,Rbbubuko.com,布布扣MUL Ra,Rbbubuko.com,布布扣MOVE Ra,Rbbubuko.com,布布扣SET Rabubuko.com,布布扣bubuko.com,布布扣functionbubuko.com,布布扣Add the number in register Ra and Rb, then store the result to Ra.bubuko.com,布布扣Subtract the number in register Ra to Rb, then store the result to Ra.bubuko.com,布布扣Divide the number in register Ra by Rb, then store the result to Ra.bubuko.com,布布扣Mulplicate the number in register Ra and Rb, then store the result to Ra.bubuko.com,布布扣Move the number in register Rb to Ra.bubuko.com,布布扣Set 0 to Ra.bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣Form 2bubuko.com,布布扣bubuko.com,布布扣


Operation code is generated according to Form 3.
Operationbubuko.com,布布扣ADDbubuko.com,布布扣SUBbubuko.com,布布扣DIVbubuko.com,布布扣MULbubuko.com,布布扣MOVEbubuko.com,布布扣SETbubuko.com,布布扣bubuko.com,布布扣Operation codebubuko.com,布布扣000001bubuko.com,布布扣000010bubuko.com,布布扣000011bubuko.com,布布扣000100bubuko.com,布布扣000101bubuko.com,布布扣000110bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣Form 3bubuko.com,布布扣bubuko.com,布布扣


Destination operator code and source operator code is the register code of the register which is related to.
There are 31 registers in total. Their names are R1,R2,R3…,R30,R31. The register code of Ri is the last 5 bits of the number of i in the binary system. For eaxample the register code of R1 is 00001, the register code of R2 is 00010, the register code of R7 is 00111, the register code of R10 is 01010, the register code of R31 is 11111.
So we can transfer an instruction into a 16-bit binary code easyly. For example, if we want to transfer the instruction ADD R1,R2, we know the operation is ADD whose operation code is 000001, destination operator code is 00001 which is the register code of R1, and source operator code is 00010 which is the register code of R2. So we joint them to get the 16-bit binary code which is 0000010000100010.
However for the instruction SET Ra, there is no source register, so we fill the lower 5 bits with five 0s. For example, the 16-bit binary code of SET R10 is 0001100101000000
You are expected to write a program to transfer an instruction into a 16-bit binary code or vice-versa.
 

Input
Multi test cases (about 50000), every case contains two lines.
First line contains a type sign, ‘0’ or ‘1’. 
‘1’ means you should transfer an instruction into a 16-bit binary code;
‘0’ means you should transfer a 16-bit binary code into an instruction.
For the second line.
If the type sign is ‘1’, an instruction will appear in the standard form which will be given in technical specification; 
Otherwise, a 16-bit binary code will appear instead.
Please process to the end of file.

[Technical Specification]
The standard form of instructions is 
ADD Ra,Rb
SUB Ra,Rb
DIV Ra,Rb
MUL Ra,Rb
MOVE Ra,Rb
SET Ra
which are also listed in the Form 2.
1a,b31bubuko.com,布布扣
There is exactly one space after operation, and exactly one comma between Ra and Rb other than the instruction SET Ra. No other character will appear in the instruction.
 

Output
For type ‘0’,if the 16-bit binary code cannot be transferred into a instruction according to the description output “Error!” (without quote), otherwise transfer the 16-bit binary code into instruction and output the instruction in the standard form in a single line.
For type ‘1’, transfer the instruction into 16-bit binary code and output it in a single line.
 

Sample Input
1 ADD R1,R2 0 0000010000100010 0 1111111111111111
 

Sample Output
0000010000100010 ADD R1,R2 Error!
 


题意:就是有6个操作,分别有对应的二进制编码表示,看上面的表,然后只有1~31的数进行加减乘除,1用00001表示,31用11111表示

这里要你翻译编码的意思;例如样例1:

1

ADD R1,R2

1代表你要把Add换成000001  然后后面R1 1的编码  00001,R2的编码00010合起来就是  0000010000100010


第二组样例就是相反的意思



不得不说的是  一定要注意 SET 操作


好了,具体解释在代码中:



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 1005

char op[10][10]={"ADD","SUB","DIV","MUL","MOVE","SET"};
char opp[10][10]={"000001","000010","000011","000100","000101","000110"};

char e[33][10]={"00000","00001","00010","00011","00100",     //请注意这个表很好,就是如果对应00011,那么就是下标3
				  "00101","00110","00111","01000","01001",
				  "01010","01011","01100","01101","01110",
				  "01111","10000","10001","10010","10011",
				  "10100","10101","10110","10111","11000",
				  "11001","11010","11011","11100","11101",
				  "11110","11111"};

char a[N],b[N],c[N];

int fdd(char *a)   //把Ra中的a取出来的函数
{
	int i,temp=0;
	int len=strlen(a);

	for(i=1;i<len;i++)
		temp=temp*10+a[i]-'0';
	return temp;
}

void solve()
{
	int i,j,pos;

	for(i=0;i<6;i++)
		if(strcmp(a,opp[i])==0)
		  break;
		pos=i;

	if(i==6)    //判断操作数是否合格
	{
		printf("Error!\n");
		return ;
	}
    if(i==5)     //如果是SET对应的000110 就单独处理
	{
		if(strcmp(c,e[0])!=0||strcmp(b,e[0])==0)   //必须满足c串对应的是0并且b串对应的数!=0,否者Error
		{
			printf("Error!\n");
		    return ;
		}
		for(i=1;i<32;i++)     
			if(strcmp(b,e[i])==0)
			break;
		printf("SET R%d\n",i);
		return ;
	}

	for(i=1;i<32;i++)
		if(strcmp(b,e[i])==0)
		break;
	j=i;
	for(i=1;i<32;i++)
		if(strcmp(c,e[i])==0)
		break;

		
    if(i>=32||j>=32)   //判断b,c串是否是e数组里的,换而言之是否合格(大于31就是不合格的)
	{
		printf("Error!\n");
		    return ;
	}
	printf("%s R%d,R%d\n",op[pos],j,i);
}

int main()
{
	int i,j,x;
	while(~scanf("%d",&x))
	{
		if(x==1)
		{
			scanf("%s%s",a,b);
			if(strcmp(a,op[5])==0)  //如果是SET单独处理
			{
				int pos=fdd(b);
				printf("%s%s00000\n",opp[5],e[pos]);
				continue;
			}
			int len=strlen(b);       //分成3段 a b c 分别代表  哪一种操作,Ra  Rb
			for(i=0;i<len;i++)
				if(b[i]==',')
				  break;
				b[i]='\0';
			j=0;
			i++;
			for(i;i<len;i)
				c[j++]=b[i++];
	        c[j]='\0';

	        for(i=0;i<6;i++)
				if(strcmp(a,op[i])==0)
				 break;
				 
			printf("%s",opp[i]);
			int pos;
			pos=fdd(b);

			printf("%s",e[pos]);
			pos=fdd(c);
			printf("%s\n",e[pos]);
		}
		else
		{
           scanf("%s",a);
           j=0;
           for(i=6;i<=10;i++)
			b[j++]=a[i];

		   j=0;
		   for(i;i<=15;i++)
			c[j++]=a[i];

		   a[6]='\0';
		   b[5]='\0';
		   c[5]='\0';

		   solve();
		}
	}

	return 0;

}



HDU 5083 Instruction(字符串处理)

标签:字符串

原文地址:http://blog.csdn.net/u014737310/article/details/40475065

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!