码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1093

时间:2019-09-19 21:34:42      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:ret   string   sub   for   result   put   mes   ring   namespace   

The string APPAPT contains two PAT‘s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT‘s contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 1 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT‘s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2


#include <bits/stdc++.h>
using namespace std;
#define N 100010
#define P pair<int,int>
#define mod 1000000007
#define ll long long 
//APPAPT 有几个不重复的PAT 
char s[N];
ll p[N],t[N];
int main()
{
    scanf("%s",s);
    int l =strlen(s);
    if(s[0]==P) p[0]=1;//因为p[-1] 
    for(int i =1;i<l;i++){
        if(s[i]==P){
            p[i]=p[i-1]+1;
        }
        else{
            p[i] = p[i-1];
        }
    }
    for(int i=l-1;i>=0;i--){
        if(s[i]==T){
            t[i]=t[i+1]+1;
        }
        else{
            t[i] = t[i+1];
        }
    }
    ll  ans = 0;
    for(int  i=0;i<l;i++){
        if(s[i]==A){
            ll  x=p[i-1];
            ll  y=t[i+1];
            ans=(ans+x*y%mod)%mod;
        }
    }
    printf("%lld\n",ans);    
    return 0;
}

 

PAT 1093

标签:ret   string   sub   for   result   put   mes   ring   namespace   

原文地址:https://www.cnblogs.com/tingtin/p/11552283.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!