码迷,mamicode.com
首页 > 其他好文 > 详细

翻转问题 Fliptile POJ - 3279

时间:2019-09-22 01:03:03      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:als   puts   linker   style   share   bool   time   try   pair   

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
//#pragma GCC optimize(2)
#pragma comment(linker, "/STACK:10240000,10240000")
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<ctime>
#include<ctype.h>
#include<stdlib.h>
#include<bitset>
#include<algorithm>
#include<assert.h>
#include<numeric> //accumulate
#define endl "\n"
#define fi first
#define se second
#define forn(i,s,t) for(int i=(s);i<(t);++i)
#define mem(a,b) memset(a,b,sizeof(a))
#define rush() int MYTESTNUM;cin>>MYTESTNUM;while(MYTESTNUM--)
#define debug(x) printf("%d\n",x)
#define inf 0x3f3f3f3f
#define INF 0x3f3f3f3f3f3f3f3f
#define mp make_pair
#define pb push_back
#define sc(x) scanf("%d",&x)
#define sc2(x,y) scanf("%d%d",&x,&y)
#define sc3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define pf(x) printf("%d\n",x)
#define pf2(x,y) printf("%d %d\n",x,y)
#define pf3(x,y,z) printf("%d %d %d\n",x,y,z)
#define ll long long
#define ull unsigned long long
#define dd double
#define pfs puts("*****")
#define pfk(x) printf("%d ",(x))
#define kpf(x) printf(" %d",(x))
#define pfdd(x) printf("%.5f\n",(x));
#define pfhh printf("\n")
using namespace std;
const ll P=1e9;
ll mul(ll a, ll b){ll ans = 0;for(;b;a=a*2%P,b>>=1) if(b&1) ans=(ans+a)%P;return ans;}
ll qpow(ll a,ll n) {ll r=1%P;for (a%=P;n;a=a*a%P,n>>=1)if(n&1)r=r*a%P;return r;}
ll inv(ll x){return x<=1?1:inv(P%x)*(P-P/x)%P;}
const int maxn=100;
inline int read()
{
    int X=0,w=0; char ch=0;
    while(!isdigit(ch)) {w|=ch==-;ch=getchar();}
    while(isdigit(ch)) X=(X<<3)+(X<<1)+(ch^48),ch=getchar();
    return w?-X:X;
}
int ma[maxn][maxn];
int aft[maxn][maxn];
int ans[maxn][maxn];
int dir[4][2]={{0,1}, {1,0}, {-1,0}, {0,-1}};
signed main()
{
    int n,m;
    sc2(n,m);
    for(int i=0;i<n;++i)
        for(int j=0;j<m;++j) sc(ma[i][j]);

    bool flag=0;
    for(int i=0; i<1<<m; ++i){

        for(int j=m-1;j>=0;--j) ans[0][j] = i>>j&1;//左右相反


        for(int k=0;k<n;++k)
            for(int j=0;j<m;++j)
                aft[k][j]=ma[k][j];

        for(int k=m-1; k>=0; --k)
            if(i>>k&1){
                aft[0][k] ^= 1;
                for(int w=0; w<4; ++w){
                    int xx=0+dir[w][0], yy=k+dir[w][1];
                    if(xx>=0 && yy>=0 && xx<n && yy<m) aft[xx][yy] ^= 1;
                }
            }

        for(int j=0; j<n-1; ++j)
            for(int k=0; k<m; ++k)
                if(aft[j][k]==1){
                    ans[j+1][k]=1;
                //reverse begin
                    aft[j+1][k] ^= 1;
                    for(int w=0; w<4; ++w){
                        int xx=j+1+dir[w][0], yy=k+dir[w][1];
                        if(xx>=0 && yy>=0 && xx<n && yy<m) aft[xx][yy] ^= 1;
                    }
                //reverse end
                }else ans[j+1][k]=0;


        bool f=1;
        for(int i=0;i<n;++i)
            for(int j=0;j<m;++j)
                if(aft[i][j]==1){
                    f=0;break;
                }
        if(f){
            for(int i=0;i<n;++i){
                for(int j=0;j<m;++j) printf("%d ",ans[i][j]);
                puts("");
            }
            flag=1;
            break;
        }
    }
    if(!flag) puts("IMPOSSIBLE");

    return 0;
}

 

翻转问题 Fliptile POJ - 3279

标签:als   puts   linker   style   share   bool   time   try   pair   

原文地址:https://www.cnblogs.com/LS-Joze/p/11565498.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!