码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3617 Best Cow Line

时间:2014-10-30 11:46:56      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:poj3617

Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10562   Accepted: 3176

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source


#include <stdio.h>
#include <string.h>

#define maxn 2010

char S[maxn];

int main() {
	int n, i, a, b, cnt, left;
	while(scanf("%d", &n) == 1) {
		for(i = 0; i < n; ++i)
			scanf("\n%c", &S[i]);
		cnt = a = 0; b = n - 1;
		while(a <= b) {
			left = 0;
			for(i = 0; a + i <= b; ++i) {
				if(S[a+i] < S[b-i]) {
					left = 1; break;
				} else if(S[a+i] > S[b-i])
					break;
			}
			if(left) putchar(S[a++]);
			else putchar(S[b--]);
			if(++cnt == 80) {
				putchar('\n');
				cnt = 0;
			}
		}
		putchar('\n');
	}
	return 0;
}


POJ3617 Best Cow Line

标签:poj3617

原文地址:http://blog.csdn.net/chang_mu/article/details/40616313

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!