码迷,mamicode.com
首页 > 其他好文 > 详细

11-散列1 电话聊天狂人 (25 分)

时间:2019-11-29 23:36:43      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:col   lan   附加   void   fir   iostream   号码   for   set   

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(10?^5??),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3
/*
6
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
13005711862 15005713862
13005711862 15005713862
*/
#include<iostream>
#include<string>
#include<map>
using namespace std;
const int maxn = 100010;

map<string, int> mp;

void Input(string str)
{
    if (mp.find(str) == mp.end())
    {
        mp[str] = 1;
    }
    else
    {
        mp[str]++;
    }
}

int main()
{
    int n;
    cin >> n;
    
    string s1,s2;
    for (int i = 0; i < n; i++)
    {
        cin >> s1 >> s2;
        Input(s1);
        Input(s2);
    }
    
    map<string, int>::iterator it = mp.begin();
    int most_time = -1;
    int most_num = 0;
    string most_ID;
    for (it = mp.begin(); it != mp.end(); it++)
    {
        //cout << "it->second = " << it->second << endl;
        if (it->second > most_time)
        {
            most_time = it->second;
            most_ID = it->first;
            most_num = 1;
        }
        else if(it->second == most_time )
        {
            most_num++;
            if (most_ID > it->first)
            {
                most_ID = it->first;
            }
        }
    }
    
    if (1 == most_num)
    {
        cout << most_ID << most_time;
    }
    else
    {
        cout << most_ID << " "<< most_time << " "<< most_num;
    }

    return 0;
}

 

 

11-散列1 电话聊天狂人 (25 分)

标签:col   lan   附加   void   fir   iostream   号码   for   set   

原文地址:https://www.cnblogs.com/wanghao-boke/p/11960779.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!