码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ2965] The Pilots Brothers' refrigerator

时间:2019-12-07 21:05:15      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:ems   you   math   air   const   oca   ges   HERE   个数   

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “?” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

\(Northeastern~Europe~2004\), \(Western~Subregion\)

题解

以下介绍两种方法:

\(DFS+\)位运算

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;

const int MAX_q=150000;
struct node
{
    int mp,x,y,nx,tot;
}q[MAX_q];
int First,c[5][5];
bool v[MAX_q];

void Init()//初始化,c[i][j]记录第i行第j列变化所引起的变化
{
    int h[5],l[5];
    for(int i=1;i<=4;++i)
        h[i]=1<<(4*i-1),
        h[i]^=1<<(4*i-2),
        h[i]^=1<<(4*i-3),
        h[i]^=1<<(4*i-4);
    for(int i=0;i<4;++i)
        l[i]=1<<i,
        l[i]^=1<<(i+4),
        l[i]^=1<<(i+8),
        l[i]^=1<<(i+12);
    for(int i=1;i<=4;++i)
        for(int j=0;j<4;++j)
            c[i][j]^=h[i]|l[j];
}

void Read()
{
    char s[5];
    for(int i=1;i<=4;++i)
    {
        scanf("%s\n",s);
        for(int j=0;j<4;++j)
            if(s[j]=='+') First^=1<<(i*4-4+j);
    }
}

void Put_Ans(int id)
{
    if(q[id].mp==First) return;
    Put_Ans(q[id].nx);
    printf("%d %d\n",q[id].x,q[id].y);
}

void Bfs()
{
    int l,r,next;
    l=0,r=1,v[First]=1;
    q[r]=(node){First,0,0,-1,0};
    while(l<=r)
    {
        ++l;
        if(!q[l].mp)
        {
            printf("%d\n",q[l].tot);
            Put_Ans(l);
            return;
        }
        for(int i=1;i<=4;++i)
            for(int j=0;j<4;++j)
            {
                next=q[l].mp^c[i][j];
                if(v[next]) continue;
                v[next]=1;//内部做访问标记减少节点扩展,优化时间
                ++r,q[r]=(node){next,i,j+1,l,q[l].tot+1};
            }
    }
}

int main()
{
    Init(),Read(),Bfs();
    return 0;
}

归纳

以下引自高效解法,供路人借鉴~

  • 要使一个为‘+‘的符号变为‘-‘,必须其相应的行和列的操作数为奇数
    • 证明:设置一个4*4的整型数组,初值为零,用于记录每个点的操作数,那么在每个‘+‘上的行和列的的位置都加1,得到结果模2(因为一个点进行偶数次操作的效果和没进行操作一样),然后计算整型数组中1的个数即为操作数,1的位置为要操作的位置(其他原来操作数为偶数的因为操作并不发生效果,因此不进行操作)
    • 推导:如果‘+‘位置对应的行和列上每一个位置都进行一次操作,则整个图只有这一‘+‘位置的符号改变,其余都不会改变

在上述证明中将所有的行和列的位置都加1后,在将其模2之前,对给定的数组状态,将所有的位置操作其所存的操作数个次数,举例,如果a[i][j]==n,则对(i,j)操作n次,当所有的操作完后,即全为‘-’的数组。

其实就是不模2的操作,作了许多的无用功。

以上的操作次序对结果无影响,如果存在一个最小的步骤,则此步骤一定在以上操作之中。(简单说下:因为以上操作已经包含了所有可改变欲改变位置的操作了)
而模2后的操作是去掉了所有无用功之后的操作,此操作同样包含最小步骤。

但模2后的操作去掉任何一个或几个步骤后,都不可能再得到全为‘-’的。(此同样可证明:因为操作次序无影响,先进行最小步骤,得到全为‘-’,如果还剩下m步,则在全为‘-’的数组状态下进行这m步操作后还得到一个全为‘-’的数组状态,此只能是在同一个位置进行偶数次操作,与前文模2后矛盾,所以m=0),因此模2后的操作即为最小步骤的操作。

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int MAXN=5;
int map[MAXN][MAXN];
queue<pair<int,int> > Q;
int main()
{
    memset(map,0,sizeof(map));
    char c;
    for (int i=1;i<=4;i++)
        for (int j=1;j<=4;j++)
        {
            c=getchar();
            while (c!='-'&&c!='+')c=getchar();
            if (c=='+')
            {
                map[i][j]=1-map[i][j];
                for (int k=1;k<=4;k++)
                {
                    map[i][k]=1-map[i][k];
                    map[k][j]=1-map[k][j];
                }
            }
        }
    int ans=0;
    for (int i=1;i<=4;i++)
        for (int j=1;j<=4;j++)
            if (map[i][j]==1)
            {
                ans++;
                Q.push(make_pair(i,j));
            }
    printf("%d\n",ans);
    pair<int,int> top;
    while (!Q.empty())
    {
        top=Q.front();Q.pop();
        printf("%d %d\n",top.first,top.second);
    }
    return 0;
}

[POJ2965] The Pilots Brothers' refrigerator

标签:ems   you   math   air   const   oca   ges   HERE   个数   

原文地址:https://www.cnblogs.com/hihocoder/p/12003167.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!