码迷,mamicode.com
首页 > 其他好文 > 详细

大小写互换

时间:2014-11-02 18:09:24      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:style   blog   io   color   ar   os   for   sp   strong   

大小写互换

描述   

  现在给出了一个只包含大小写字母的字符串,不含空格和换行,要求把其中的大写换成小写,小写换成大写,然后输出互换后的字符串。

 
输入
第一行只有一个整数m(m<=10),表示测试数据组数。 接下来的m行,每行有一个字符串(长度不超过100)。
输出
输出互换后的字符串,每组输出占一行。
样例输入
2
Acm
ACCEPTED
样例输出
aCM
accepted

 
#include<iostream>
#include <string>
 using namespace std;
 

 char inverse(char ch)
 {
     if(ch>=a)
         return ch-32;
     else 
         return ch + 32;
 }
 int main()
 {
int n;
string str;
cin>>n;
while(n--)
{
    cin>>str;
    int num = str.size();
    for(int i = 0;i <num; i++)
    {
    cout<<    inverse(str[i]);
        
    }
    cout<<endl;
}
 return 0;
 }        

 

大小写互换

标签:style   blog   io   color   ar   os   for   sp   strong   

原文地址:http://www.cnblogs.com/imwtr/p/4069587.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!