码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1136 A Delayed Palindrome (20分)

时间:2020-01-27 17:31:19      阅读:64      评论:0      收藏:0      [点我收藏+]

标签:contain   board   inner   mes   red   one   art   int   word   

Consider a positive integer N written in standard notation with k+1 digits a?i?? as a?k???a?1??a?0?? with 0 for all i and a?k??>0. Then N is palindromic if and only if a?i??=a?ki?? for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
 

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152
 

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
 

Sample Input 2:

196
 

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

这道题考察了大数的加减、回文数。

c++解法:

#include <iostream>
#include <algorithm>
using namespace std;
string plus_str(string s1,string s2){
    reverse(s1.begin(),s1.end());
    reverse(s2.begin(),s2.end());
    string res="";int i;bool jinwei=false;
    for(i=0;i<s2.size();i++){
        if(jinwei) {
            res+=((s1[i]-0+s2[i]+1-0)%10+0);
            jinwei=false;
            if((s1[i]-0+s2[i]-0+1)/10>0) jinwei=true;
        }
        else {
            res+=((s1[i]-0+s2[i]-0)%10+0);
            if((s1[i]-0+s2[i]-0)/10>0) jinwei=true;
        }
    }
    if(jinwei) res+=1;
    reverse(res.begin(),res.end());
    return res;
}
int main()
{
    string str,rev,add;int n=10;
    cin>>str;
    while(n--){
        rev=str;
        reverse(rev.begin(),rev.end());
        if(str==rev) {
            printf("%s is a palindromic number.",str.data());
            system("pause");
            return 0;
        }
        add=plus_str(str,rev);
        printf("%s + %s = %s\n",str.data(),rev.data(),add.data());
        str=add;
    }
    printf("Not found in 10 iterations.");
return 0; }

Java解法

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        BigInteger num = sc.nextBigInteger();    
        for(int i = 0; i < 10; i++){
            BigInteger revNum = new BigInteger(new StringBuilder(num+"").reverse().toString());
            if(num.equals(revNum)) {
                System.out.printf("%s is a palindromic number.\n", num.toString());
                return ;
            }
            else {
                BigInteger plus = num.add(revNum);
                System.out.printf("%s + %s = %s\n", num, revNum, plus);
                num = plus;
            }
        }
        System.out.println("Not found in 10 iterations.");
    }
}

PAT Advanced 1136 A Delayed Palindrome (20分)

标签:contain   board   inner   mes   red   one   art   int   word   

原文地址:https://www.cnblogs.com/littlepage/p/12236281.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!