码迷,mamicode.com
首页 > 其他好文 > 详细

7-21 Counting Leaves (30分)

时间:2020-02-04 20:31:43      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:while   hat   ace   starting   ecif   ever   cli   inpu   family   

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

The input consists of several test cases, each starts with a line containing 0, the number of nodes in a tree, and M (<), the number of non-leaf nodes. Then M lines follow, each in the format ID K ID[1] ID[2] ... ID[K] where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

For example, the first sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02
1 0
7 4
01 2 02 03
06 1 07
02 2 04 05
03 1 06
0 0
 

Sample Output:

0 1
1
0 0 2 1

代码:
#include <stdio.h>
#include <stdlib.h>
struct Node {
    int index;
    int c[101];
}s[101];
int leave[101];
int mheight;
void count(int id,int height) {
    if(mheight < height)mheight = height;
    if(s[id].index == 0) {
        leave[height] ++;
        return;
    }
    for(int i = 0;i < s[id].index;i ++)
        count(s[id].c[i],height + 1);
}
int main() {
    int n,m,k,id,d;
    while(scanf("%d%d",&n,&m) && n) {
        mheight = 0;
        for(int i = 0;i <= n;i ++) {
            leave[i] = s[i].index = 0;
        }
        for(int i = 0;i < m;i ++) {
            scanf("%d%d",&id,&k);
            s[id].index = 0;
            while(k --) {
                scanf("%d",&d);
                s[id].c[s[id].index ++] = d;
            }
        }
        count(1,0);
        printf("%d",leave[0]);
        for(int i = 1;i <= mheight;i ++)
            printf(" %d",leave[i]);
        putchar(\n);
    }
}

 

7-21 Counting Leaves (30分)

标签:while   hat   ace   starting   ecif   ever   cli   inpu   family   

原文地址:https://www.cnblogs.com/8023spz/p/12260758.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!