码迷,mamicode.com
首页 > 其他好文 > 详细

a letter and a number

时间:2014-11-04 22:48:38      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:style   io   ar   for   sp   数据   div   on   代码   



a letter and a number描述

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
解题思路:
本题涉及n组数据,而每组数据开头都是字符,scanf读取字符是会先读取换行,所以应当在读取每行数据之前,用getchar将回车吃掉,否知只能读取一半数据。
程序代码:
#include<stdio.h>
int main()
{
	int n,y,i;
	char x;
	scanf("%d",&n);
	while(n--)
	{
		getchar();
		scanf("%c%d",&x,&y);
		if(x>='a'&&x<='z')
			printf("%d\n",'a'-x-1+y);
		else if(x>='A'&&x<='Z')
			printf("%d\n",x-'A'+1+y);

	}
	return 0;
}

a letter and a number

标签:style   io   ar   for   sp   数据   div   on   代码   

原文地址:http://blog.csdn.net/yzi_angel/article/details/40794017

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!