码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1273 Drainage Ditches

时间:2020-03-10 22:03:17      阅读:54      评论:0      收藏:0      [点我收藏+]

标签:format   OWIN   problem   pat   direct   style   HERE   poi   The   

地址  http://poj.org/problem?id=1273

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

网络流 解答

// 11111111111.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//

#include <iostream>
#include <queue>

using namespace std;

/*
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
*/
const int maxn = 220;
const int inf = 0x7f7f7f7f;

int G[maxn][maxn], flow[maxn],pre[maxn];
int n, m;
queue<int> q;

int bfs(int s, int t)
{
    while (!q.empty()) q.pop();
    memset(pre, -1, sizeof(pre));
    pre[s] = -1; flow[s] = inf;
    q.push(s);
    while (!q.empty()) {
        int p = q.front(); q.pop();
        if (p == t) break;
        for (int u = 1; u <= n; u++) {
            if (u != s && G[p][u] > 0 && pre[u] == -1) {
                pre[u] = p;
                flow[u] = min(flow[p], G[p][u]);
                q.push(u);
            }
        }
    }
    if (pre[t] == -1) return -1;
    return flow[t];
}

int EK(int s, int t)
{
    int delta = 0, tot = 0;
    while (1) {
        delta = bfs(s, t);
        if (delta == -1) break;
        int p = t;
        while (p != s) {
            G[pre[p]][p] -= delta;
            G[p][pre[p]] += delta;
            p = pre[p];
        }
        tot += delta;
    }

    return tot;
}


int main()
{
    int u, v, w;
    while (~scanf("%d%d", &m, &n)) {
        memset(G, 0, sizeof(G));
        memset(flow, 0, sizeof(flow));
        for (int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            G[u][v] += w;
        }
        printf("%d\n", EK(1, n));
    }

    return 0;
}

 

poj 1273 Drainage Ditches

标签:format   OWIN   problem   pat   direct   style   HERE   poi   The   

原文地址:https://www.cnblogs.com/itdef/p/12458700.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!