码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj 2021 发工资咯:)

时间:2020-03-20 22:11:07      阅读:79      评论:0      收藏:0      [点我收藏+]

标签:数据   tle   similar   col   c语言   printf   ref   hdoj   php   

Problem Description
作为杭电的老师,最盼望的日子就是每月的8号了,因为这一天是发工资的日子,养家糊口就靠它了,呵呵
但是对于学校财务处的工作人员来说,这一天则是很忙碌的一天,财务处的小胡老师最近就在考虑一个问题:如果每个老师的工资额都知道,最少需要准备多少张人民币,才能在给每位老师发工资的时候都不用老师找零呢?
这里假设老师的工资都是正整数,单位元,人民币一共有100元、50元、10元、5元、2元和1元六种。
 

 

Input
输入数据包含多个测试实例,每个测试实例的第一行是一个整数n(n<100),表示老师的人数,然后是n个老师的工资。
n=0表示输入的结束,不做处理。
 

 

Output
对于每个测试实例输出一个整数x,表示至少需要准备的人民币张数。每个输出占一行。
 

 

Sample Input
3 1 2 3 0
 

 

Sample Output
4
 

 

Author
lcy
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2022 2023 2024 2025 2026 
 
贪心算法寻找最优解
代码如下:
#include<stdio.h>
#include<malloc.h>
int main()
{
    int n=0;
    int s=0;
    while(scanf("%d",&n)!=EOF)
    {
        s=0;
        if(n==0)
            break;
        int *a=(int *)malloc(sizeof(int)*n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
        {
            while(a[i]>=100)
            {
                a[i]-=100;
                s++;
            }
            while(a[i]>=50)
            {
                a[i]-=50;
                s++;
            }
            while(a[i]>=10)
            {
                a[i]-=10;
                s++;
            }
            while(a[i]>=5)
            {
                a[i]-=5;
                s++;
            }
            while(a[i]>=2)
            {
                a[i]-=2;
                s++;
            }
            while(a[i]>=1)
            {
                a[i]-=1;
                s++;
            }
            
            
         }
    printf("%d\n",s); 
    }
 }

 

HDoj 2021 发工资咯:)

标签:数据   tle   similar   col   c语言   printf   ref   hdoj   php   

原文地址:https://www.cnblogs.com/wzmm/p/12534918.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!