码迷,mamicode.com
首页 > 其他好文 > 详细

A - Til the Cows Come Home POJ - 2387

时间:2020-03-30 00:21:16      阅读:101      评论:0      收藏:0      [点我收藏+]

标签:app   red   pos   namespace   length   uniq   return   map   trail   

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.


Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
 
 
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <set>
#include <queue>
#include <map>
#include <sstream>
#include <cstdio>
#include <cstring>
#include <numeric>
#include <cmath>
#include <iomanip>
#include <deque>
//#include <unordered_set>
//#include <unordered_map>
//#include <xfunctional>
#define ll  long long
#define PII  pair<int, int>
using namespace std;
int dir[5][2] = { { 0,1 } ,{ 0,-1 },{ 1,0 },{ -1,0 } ,{ 0,0 } };
const long long INF = 0x7f7f7f7f7f7f7f7f;
const int inf = 0x3f3f3f3f;
const double pi = 3.14159265358979;
const int mod = 1e9 + 7;
const int maxn = 1100;
//if(x<0 || x>=r || y<0 || y>=c)
//1000000000000000000

int edge[maxn][maxn];
vector<bool> vis(maxn, false);
vector<int> dis(maxn, inf);
int t, n;
void dijkstra(int x)
{
    int v = x;
    dis[v] = 0;
    vis[v] = 1;
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            if (vis[j] == false && dis[v] + edge[v][j]<dis[j])
            {
                dis[j] = dis[v] + edge[v][j];
            }
        }
        int minn = inf;
        for (int j = 1; j <= n; j++)
        {
            if (vis[j] != 1 && dis[j]<minn)
            {
                minn = dis[j];
                v = j;
            }
        }
        vis[v] = 1;
    }
}
int main()
{
    cin >> t >> n;
    for (int i = 0; i < maxn; i++)
    {
        for (int j = 0; j < maxn; j++)
        {
            edge[i][j] = inf;
        }
        edge[i][i] = 0;
    }
    for (int i = 1; i <= t; i++)
    {
        int u, v, w;
        cin >> u >> v >> w;
        if (edge[u][v]>w)
        {
            edge[v][u] = w;
            edge[u][v] = w;
        }
    }
    dijkstra(1);
    cout << dis[n];
    return 0;
}

 

 

A - Til the Cows Come Home POJ - 2387

标签:app   red   pos   namespace   length   uniq   return   map   trail   

原文地址:https://www.cnblogs.com/dealer/p/12595927.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!