码迷,mamicode.com
首页 > 其他好文 > 详细

1090 Highest Price in Supply Chain

时间:2020-04-03 00:24:56      阅读:77      评论:0      收藏:0      [点我收藏+]

标签:amp   else   boa   The   man   exce   模拟   positive   rom   

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S?i?? is the index of the supplier for the i-th member. S?root?? for the root supplier is defined to be −. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6
 

Sample Output:

1.85 2

题意:

给出商品的供应链,每一条链之间都会提高r%(相对于进价而言),找到最高的价格,也就是找到最长的供应链,并指出最长的供应链有几条。

思路:

这种题目如果用对数据结构的话会很简单,这一题用到了queue和map,map给出谁是供应者,谁是被供应者,queue用来模拟层次遍历,最长的供应链,也就是最大的层数。

 

Code:

#include<iostream>
#include<map>
#include<iomanip>
#include<vector>
#include<queue>

using namespace std;

int main() {
    int n;
    double p, r;
    cin >> n >> p >> r;

    int t;
    vector<int> chain(n);
    for (int i = 0; i < n; ++i) {
        cin >> t;
        chain[i] = t;
    }
    map<int, vector<int> > mp;
    int last;
    for (int i = 0; i < n; ++i) {
        last = chain[i];
        mp[last].push_back(i);
    }

    auto it = mp.find(-1);
    vector<int> v = it->second;
    queue<int> q;
    for (int i = 0; i < v.size(); ++i)
        q.push(v[i]);
    q.push(-1);
    int len = 0, num = 0;
    while(!q.empty()) {
        if (q.size() == 1) break;
        int f = q.front();
        q.pop();
        num++;
        if (f == -1) {
            len++;
            num = 0;
            q.push(-1);
        } else {
            if (mp.find(f) != mp.end()) {
                v = mp.find(f)->second;
                for (int i = 0; i < v.size(); ++i)
                    q.push(v[i]);
            }
        }
    }

    double heighPrice = p;
    for (int i = 0; i < len; ++i) {
        heighPrice *= (1 + r/100);
    }

    cout << fixed << setprecision(2) << heighPrice << " " << num << endl;
    
    return 0;
}

  

看到全部的数据都通过了,也可以睡觉了。

 

1090 Highest Price in Supply Chain

标签:amp   else   boa   The   man   exce   模拟   positive   rom   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12623938.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!