码迷,mamicode.com
首页 > 其他好文 > 详细

Cable master HDU - 1551 —— 二分基础模板(精度问题)

时间:2020-04-06 10:14:07      阅读:91      评论:0      收藏:0      [点我收藏+]

标签:assigned   view   思路   single   sample   cli   std   while   图片   

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
InputThe input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0‘s.
OutputFor each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
0 0
Sample Output
2.00

题意:给你n段绳子分成k段,问当分成k段得到时候最短的长度是多少。

思路:利用二分查找答案,每次一直逼近极限(注意精度!!!

代码:

技术图片
#include <iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <string>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <unordered_map>
#define Fbo friend bool operator < (node a, node b)
#define mem(a, b) memset(a, b, sizeof(a))
#define FOR(a, b, c) for(int a = b; a <= c; a++)
#define RFOR(a,b, c) for(int a = b; a >= c; a--)
#define sc(a) scanf("%d",&a)
#define off ios::sync_with_stdio(0)
bool check1(int a) { return (a & (a - 1)) == 0 ? true : false; }

using namespace std;
typedef pair<int, int> pii;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const int Maxn = 2e5 + 5;
const double pi = acos(-1.0);
const double eps = 1e-9;

double a[Maxn];
int n, k;

int solve(double mid) { //设每段绳子长度为mid,看所有能不能截成k段
    int sum = 0;
    FOR(i, 1, n) {
        sum += int(a[i] / mid); //分的段数
    }
    if (sum >= k) //如果满足要求
        return 1;
    return 0;
}

int main() {
    while (~scanf("%d%d", &n, &k)) {
        if (n == 0 && k == 0)break;
        FOR(i, 1, n) {
            scanf("%lf", &a[i]);
        }
        sort(a + 1, a + 1 + n);
        double l = 1.00, r = a[n];
        double mid;
        while (r - l > eps) { //注意精度
            mid = (l + r) / 2;
            if (solve(mid)) {
                l = mid;
            }
            else r = mid;
        }
        printf("%.2f\n", mid);
    }
    return 0;
}
View Code

 

Cable master HDU - 1551 —— 二分基础模板(精度问题)

标签:assigned   view   思路   single   sample   cli   std   while   图片   

原文地址:https://www.cnblogs.com/AlexLINS/p/12640404.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!