码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1077 Eight(bfs+康托展开)

时间:2020-04-07 20:40:18      阅读:86      评论:0      收藏:0      [点我收藏+]

标签:accept   move   移动   lru   struct   http   poj   each   i++   

Eight
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 41040   Accepted: 16901   Special Judge

Description

The 15-puzzle has been around for over 100 years; even if you don‘t know it by that name, you‘ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let‘s call the missing tile ‘x‘; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4 

5 6 7 8
9 10 11 12
13 14 15 x

where the only legal operation is to exchange ‘x‘ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->

The letters in the previous row indicate which neighbor of the ‘x‘ tile is swapped with the ‘x‘ tile at each step; legal values are ‘r‘,‘l‘,‘u‘ and ‘d‘, for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x‘ tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x‘. For example, this puzzle
 1  2  3 

x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable‘‘, if the puzzle has no solution, or a string consisting entirely of the letters ‘r‘, ‘l‘, ‘u‘ and ‘d‘ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

题目大意与分析

输入一个3x3的棋盘,每次将0上下左右移动,直到变换成为123456780的状态,求最短路线

BFS+Contor变换,康托展开公式:

技术图片

 

 以此求得的是在当前状态前面的状态数量

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <queue>
#include <string> 
using namespace std;

struct node
{
    int s[9];
    string road;
    int order;
    int add0;
};
struct node start;
int jiecheng[10],f[2][4]={0,0,-1,1,-1,1,0,0},vis[400005],flag=0;
string anss;
char fang[5]="lrud";
int Contor(int s[],int n)
{
    int order=0;
    for(int i=0;i<n;i++)
    {
        int num=0;
        for(int j=i+1;j<n;j++)
        {
            if(s[j]<s[i])
            num++;
        }
        order+=num*jiecheng[n-i-1];
    }
    return order+1;
}

void bfs()
{
    queue<struct node>q;
    q.push(start);
    vis[start.order]=1;
    while(!q.empty())
    {
        struct node now=q.front();
        if(now.order==46234)
        {
            flag=1;
            anss=now.road;
            break;
        }
        q.pop();
        int x=now.add0/3;
        int y=now.add0%3;
        int i;
        for(i=0;i<4;i++)
        {
            int xx=x+f[0][i];
            int yy=y+f[1][i];
            if(xx>=0&&xx<3&&yy>=0&&yy<3)
            {
                int add1=xx*3+yy;
                struct node next=now;
                next.add0=add1;
                next.s[now.add0]=next.s[add1];
                next.s[add1]=0;
                next.add0=add1;
                next.order=Contor(next.s,9);
                if(vis[next.order]==0)
                {
                    vis[next.order]=1;
                    next.road=now.road+fang[i];
                    q.push(next);
                }
            }
        }
    }
}

int main()
{
    char x;
    for(int i=0;i<9;i++)
    {
        cin>>x;
        if(x==x)
        {
            start.s[i]=0;
            start.add0=i;
        }
        else
        start.s[i]=x-0;
    }
    start.order=Contor(start.s,9);
    jiecheng[0]=1;
    for(int i=1;i<=9;i++)
    {
        jiecheng[i]=i*jiecheng[i-1];
    }
    bfs();
    if(flag)
    cout<<anss<<endl;
    else
    cout<<"unsolvable"<<endl;
 } 

 

POJ 1077 Eight(bfs+康托展开)

标签:accept   move   移动   lru   struct   http   poj   each   i++   

原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/12655476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!