码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ-3984]迷宫问题

时间:2020-04-09 01:03:50      阅读:74      评论:0      收藏:0      [点我收藏+]

标签:不能   name   数据   const   second   std   using   bfs   ||   

题目描述

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0

0 1 0 1 0

0 0 0 0 0

0 1 1 1 0

0 0 0 1 0

Sample Output

(0, 0)

(1, 0)

(2, 0)

(2, 1)

(2, 2)

(2, 3)

(2, 4)

(3, 4)

(4, 4)

题目分析

很简单的一道题,dfs输出路径,只需要再开一个Pre数组,当执行d[x][y] = d[t.first][t.second] + 1;这一步骤时,用Pre数组记录一下(x,y)是从(t.first,t.second)走到的就行了
其余见代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N = 10;
typedef struct node
{
    int first;
    int second;
} PII;
queue<PII> q;
PII Pre[N][N],ans[N];
int g[N][N],d[N][N];
int dx[] = {1,0,-1,0},dy[] = {0,1,0,-1};
int bfs()
{
    PII e;
    e.first = 0,e.second = 0;
    q.push(e);
    memset(d,-1,sizeof d);
    d[0][0] = 0;
    while (q.size())
    {
        PII t = q.front();
        q.pop();
        for(int i = 0;i<4;i++)
        {
            int x = t.first + dx[i],y = t.second + dy[i];
            if(g[x][y] == 0&&d[x][y] == -1&&x>=0&&y>=0&&x<5&&y<5)
            {
                d[x][y] = d[t.first][t.second] + 1;
                Pre[x][y] = t;
                e.first = x,e.second = y;
                q.push(e);
            }
        }
    }
    int x = 4,y = 4,i = 0;
    while(x||y)
    {
        PII t = Pre[x][y];
        ans[i] = t;
        x = t.first,y = t.second;
        i++;
    }
    return i;
}
int main()
{
    for(int i = 0;i<5;i++)
        {
            for(int j = 0;j<5;j++)
            {
                cin>>g[i][j];
            }
        }
    int t = bfs();
    for(int i = t-1;i>=0;i--)
    {
        cout<<‘(‘<<ans[i].first<<", "<<ans[i].second<<‘)‘<<endl;
    }
    printf("(4, 4)\n");
    return 0;
}

[POJ-3984]迷宫问题

标签:不能   name   数据   const   second   std   using   bfs   ||   

原文地址:https://www.cnblogs.com/Trouni/p/12663889.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!