码迷,mamicode.com
首页 > 其他好文 > 详细

1075 PAT Judge

时间:2020-04-30 23:17:34      阅读:62      评论:0      收藏:0      [点我收藏+]

标签:int   must   nta   tps   ast   inf   ++i   win   rank   

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤), the total number of users, K (≤), the total number of problems, and M (≤), the total number of submissions. It is then assumed that the user id‘s are 5-digit numbers from 00001 to N, and the problem id‘s are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
 

where partial_score_obtained is either − if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]
 

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id‘s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
 

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

 

题意:

  根据分数进行排序。

思路:

  这种题难道是不难就是细节太多,有一点忽略掉的话,就会被样例卡掉,更重要的是当自己写好代码之后还信心满满的认为自己写的是对的,找起bug来真的很难。

Code:

#include <bits/stdc++.h>

using namespace std;

struct User {
    int id;
    int rank;
    int total_score = 0;
    int NumOfPerfect = 0;
    bool shown = false;
    vector<int> problems;
};

bool cmp(User a, User b) {
    if (a.total_score != b.total_score)
        return a.total_score > b.total_score;
    else if (a.NumOfPerfect != b.NumOfPerfect)
        return a.NumOfPerfect > b.NumOfPerfect;
    else
        return a.id < b.id;
}

int main() {
    int n, k, m;
    cin >> n >> k >> m;
    vector<int> score(k + 1);
    for (int i = 1; i <= k; ++i) cin >> score[i];
    vector<User> users(n + 1);
    int user_id, pro_id, pso;
    for (int i = 1; i <= n; ++i) users[i].problems.resize(k + 1, -1);
    for (int i = 0; i < m; ++i) {
        cin >> user_id >> pro_id >> pso;
        users[user_id].id = user_id;
        int temp = users[user_id].problems[pro_id];
        users[user_id].problems[pro_id] = max(pso, temp);
        if (pso != -1)
            users[user_id].shown = true;
        else if (users[user_id].problems[pro_id] == -1)
            users[user_id].problems[pro_id] = -2;
    }
    for (int i = 1; i <= n; ++i) {
        for (int j = 1; j <= k; ++j) {
            if (users[i].problems[j] != -1 && users[i].problems[j] != -2)
                users[i].total_score += users[i].problems[j];
            if (users[i].problems[j] == score[j]) users[i].NumOfPerfect++;
        }
    }
    sort(users.begin() + 1, users.end(), cmp);

    for (int i = 1; i <= n; ++i) {
        users[i].rank = i;
        if (i != 1 && users[i].total_score == users[i - 1].total_score)
            users[i].rank = users[i - 1].rank;
    }
    for (int i = 1; i <= n; ++i) {
        if (users[i].shown) {
            printf("%d %05d %d", users[i].rank, users[i].id,
                   users[i].total_score);
            for (int j = 1; j <= k; ++j) {
                if (users[i].problems[j] != -1 && users[i].problems[j] != -2)
                    printf(" %d", users[i].problems[j]);
                else if (users[i].problems[j] == -1)
                    printf(" -");
                else
                    printf(" 0");
            }
            printf("\n");
        }
    }
    return 0;
}

 

参考:

  https://www.liuchuo.net/archives/2260

 

1075 PAT Judge

标签:int   must   nta   tps   ast   inf   ++i   win   rank   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12811415.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!