码迷,mamicode.com
首页 > 其他好文 > 详细

PAT A1109 Group Photo (25) [逻辑题]

时间:2020-05-02 21:01:34      阅读:57      评论:0      收藏:0      [点我收藏+]

标签:题目   must   logs   sample   hid   any   www   cat   易错点   

题目

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:
The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
All the people in the rear row must be no shorter than anyone standing in the front rows;
In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1),where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the lef of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your lef-hand side is the right-hand side of the one at the central position.);
When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.
Now given the information of a group of people, you are supposed to write a program to output their formation.
Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).
Output Specification:
For each case, print the formation — that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.
Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

题目分析

n个人照相,k行,多余的人都站在最后一行
每行身高最高者站在最中间,然后按照升序左一个右一个直到排满

解题思路

  1. 接收数据,并排序(身高降序,若身高相同,名字字母序升序)
  2. 摆放数据,当前排m个人,当前排信息存储于一维数组容器中
    2.1 每排身高最高者,即区间内第一个,置于中点m/2;
    2.2 摆放左边,步长为2,起始为m+1
    2.3 摆放右边,步长为2,起始为m+2

易错点

  1. 无需将所有摆放好位置的数据存储于二维数组容器中,浪费资源和时间
  2. 中点的设置,因为数组是从0开始,所以中点为m/2,而不是题目中的m/2+1

Code

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
struct person {
	int h;
	char name[10];
};

bool cmp(person &p1, person &p2) {
	if(p1.h!=p2.h)return p1.h>p2.h;
	else return strcmp(p1.name,p2.name)<0;
}
int main(int argc,char * argv[]) {
	int n,k,h;
	scanf("%d %d",&n,&k);
	int row=k;
	int rear=n/k+n%k;
	int other=n/k;
	vector<person> ps(n);
	char name[10];
	for(int i=0; i<n; i++) {
		scanf("%s %d",ps[i].name,&ps[i].h);
	}
	sort(ps.begin(),ps.end(),cmp);
	int t=0;
	while(row) {
		int m=n/k;;
		if(row==k) m+=n%k; //队伍最后一行人数
		vector<string> cps(m);
		cps[m/2]=ps[t].name;
		// 填充中点左边
		int j=m/2-1;
		for(int i=t+1; i<t+m; i+=2) {
			cps[j--]=ps[i].name;
		}
		// 填充中点右边
		j=m/2+1;
		for(int i=t+2; i<t+m; i+=2) {
			cps[j++]=ps[i].name;
		}
		// 输出当前排
		printf("%s",cps[0].c_str());
		for(int i=1; i<cps.size(); i++) {
			printf(" %s", cps[i].c_str());
		}
		printf("\n");
		t+=m;
		row--;
	}
	return 0;
}

技术图片

PAT A1109 Group Photo (25) [逻辑题]

标签:题目   must   logs   sample   hid   any   www   cat   易错点   

原文地址:https://www.cnblogs.com/houzm/p/12819219.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!