码迷,mamicode.com
首页 > 其他好文 > 详细

1128 N Queens Puzzle (20分)

时间:2020-05-05 20:21:48      阅读:56      评论:0      收藏:0      [点我收藏+]

标签:nts   repr   sha   sep   ima   red   can   boa   diagonal   

The "eight queens puzzle" is the problem of placing eight chess queens on an 8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (, where Q?i?? is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens‘ solution.

技术图片 技术图片
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1). Then K lines follow, each gives a configuration in the format "Q?1?? Q?2?? ... Q?N??", where 4 and it is guaranteed that 1 for all ,. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
 

Sample Output:

YES
NO
NO
YES

N皇后问题,我们给定K个测试用例,给定N皇后,(i, N)为皇后坐标,查询给定用例皇后不在同行,同列,同斜线,如果满足,则输出YES,否则输出NO

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
int main() {
    int K, N, tmp;
    scanf("%d", &K);
    while(K--) {
        scanf("%d", &N);
        vector<pair<int, int>> v;
        bool no = false;
        for(int c = 0; c < N; c++) {
            scanf("%d", &tmp);
            for(auto x: v) {
                if(x.first == c || x.second == tmp || ((x.first - c) == (x.second - tmp) && (x.first - c) * (x.second - tmp) > 0))
                    no = true;
            }
            v.push_back({c, tmp});
        }
        printf("%s\n", no ? "NO" : "YES");
    }
    return 0;
}

 

1128 N Queens Puzzle (20分)

标签:nts   repr   sha   sep   ima   red   can   boa   diagonal   

原文地址:https://www.cnblogs.com/littlepage/p/12831903.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!