码迷,mamicode.com
首页 > 其他好文 > 详细

1019 General Palindromic Number (20分)

时间:2020-05-08 22:46:30      阅读:65      评论:0      收藏:0      [点我收藏+]

标签:math   结果   where   else   hat   written   hint   sel   cli   

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits a?i?? as (. Here, as usual, 0 for all i and a?k?? is non-zero. Then N is palindromic if and only if a?i??=a?ki?? for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a?k?? a?k1?? ... a?0??". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
 

Sample Output 1:

Yes
1 1 0 1 1
 

Sample Input 2:

121 5
 

Sample Output 2:

No
4 4 1
#include<iostream>
using namespace std;

int main()
{
    int arr[30],brr[30];
    long long a,b;//先输入a , b 数字和要转的进制
    cin>>a>>b;
    int i=0;
    while(a>0)//转为b进制
    {
        arr[i++] = a % b;
        a = a/b;
    }
    
    int flag = 1;//flag=1 表示结果是回文数
    
    for(int j = 0;j<i/2;j++)
    {
        if(arr[j]!=arr[i-j-1])
        {
            flag = 0 ;//不是回文数
            break; 
        }
        
    }
    
    if(flag==1)
        printf("Yes\n");
    else
    
        printf("No\n");
  if(i==0)//如果输入的是0
  {
    printf("0");
   return 0; 
  }
    i--;//i表示转换后一共有i位
    while(i)
    {
        if(i!=0)
            cout<<arr[i--]<<" ";
        if(i==0)
            cout<<arr[0];
    }
    
  
    
    
    return 0;
}
 

 

1019 General Palindromic Number (20分)

标签:math   结果   where   else   hat   written   hint   sel   cli   

原文地址:https://www.cnblogs.com/qinmin/p/12853461.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!