码迷,mamicode.com
首页 > 其他好文 > 详细

1024 Palindromic Number (25分)

时间:2020-05-14 01:07:23      阅读:59      评论:0      收藏:0      [点我收藏+]

标签:ring   via   integer   tom   rom   rev   case   cin   not   

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3
 

Sample Output 1:

484
2
 

Sample Input 2:

69 3
 

Sample Output 2:

1353
3


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

bool ishuiwen(string s)//判别是否回文
{
    int num = s.size();
    for(int i=0;i<num;i++)
    {
        if(s[i]!=s[num-i-1])
            return 0;
    }

    return 1;
}

string adder(string t)//你序后再相加
{
    string tm = t;//copy t
    reverse(t.begin(),t.end());//逆转t
    int sizee = t.size();
    int carry = 0;
    for(int i=sizee-1;i>=0;i--)
    {
        int num = tm[i]-0;
        num = t[i]-0 + num +carry;
        carry = 0;
        if(num>=10)
        {
            carry = 1;
            num = num -10;
        }
        tm[i] = num +0;
    }
    if(carry==1)
        tm = 1+tm;


    return tm;

}
int main()
{
    string n;
    int k;
    cin>>n>>k;
     if(ishuiwen(n))//判断一输入的数字是否本身就是回文数
        {
            cout<<n<<endl;
            printf("%d",0);
         return 0;
        }
    for(int i=0;i<k;i++)
    {
        

        n = adder(n);

        if(ishuiwen(n))
        {
            cout<<n<<endl;
            printf("%d",i+1);
            return 0;
        }

    }


            cout<<n<<endl;
            printf("%d",k);


    return 0;

}

 

1024 Palindromic Number (25分)

标签:ring   via   integer   tom   rom   rev   case   cin   not   

原文地址:https://www.cnblogs.com/qinmin/p/12885713.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!