码迷,mamicode.com
首页 > 其他好文 > 详细

竖式问题

时间:2020-05-18 22:36:33      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:inf   方式   ack   编号   scanf   style   strlen   turn   return   

题目

找出所有形如abc*de(三位数乘以两位数)的算式,使得在完整的竖式中,所有数字都属于一个特定的数字集合。

输入数字集合(相邻数字之间没有空格),输出所有竖式。

每个竖式前应有编号,之后应有一个空行。最后输出解的总数。

具体格式见样例输出(为了便于观察,竖式中的空格改用小数点显示,但所写程序中应该输出空格,而非小数点)。

样例输入:

2357

样例输出:

<1>

 . . 7 7 5

x . .  3 3

_ _ _ _ _

. 2 3 2 5

23 2 5 .

_ _ _ _ _

25 5 7 5

 

The number of solutions = 1

 

分析

尝试所有的abc和de,判断是否满足条件。

伪代码如下:

char s[20] ;
int count = 0;
scanf("%s",s) ;
for(int abc=111;abc<=999;abc++)
{
    for(int de=11;de<=99;de++)
    {
        if("abc*de是个合法的竖式")
        {
            printf("<%d>\n",count) ;
            打印abc*de的竖式和其后的空行
            count++; 
        } 
    } 
} 
printf("The number of solutions = %d\n",count);

 

c实现

#include<stdio.h>
#include<string.h>
int main()
{
    int count=0;
    char s[20],buf[99];
    scanf("%s",s);
    //printf("%s\n",s) ;  //仅记录输出字符串变量的打印方式 
    for(int abc=111;abc<=999;abc++)
    {
        for(int de=11;de<=99;de++)
        {
            int x=abc*(de%10),y=abc*(de/10),z=abc*de;
            sprintf(buf,"%d%d%d%d%d",abc,de,x,y,z);
            int ok=1;
            for(int i=0;i<=strlen(buf);i++){
                //strchr表示在s中查找buf[i],即buf中每个字符都包含在s中 
                if(strchr(s,buf[i])== NULL) ok=0;
            }
            // 若buf中每个字符都包含在s中 ,则为合法的竖式 
            if(ok)
            {
                printf("<%d>\n",++count);
                printf("%5d\nX%4d\n-----\n%5d\n%4d\n-----\n%5d\n\n",abc,de,x,y,z);
            }
        } 
    }
    printf("The number of solutions = %d\n",count);
    return 0;
}

//竖式问题 

 

效果

示例1:输入2357

技术图片

 

 示例2:输入2389

技术图片

 

 示例3:输入1389

技术图片

 

竖式问题

标签:inf   方式   ack   编号   scanf   style   strlen   turn   return   

原文地址:https://www.cnblogs.com/Vincent-yuan/p/12913143.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!