码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1832 Luck and Love (二维线段树)

时间:2014-11-07 19:06:36      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   数据   div   

Problem Description
世界上上最远的距离不是相隔天涯海角
而是我在你面前
可你却不知道我爱你
                ―― 张小娴

前段日子,枫冰叶子给Wiskey做了个征婚启事,聘礼达到500万哦,天哪,可是天文数字了啊,不知多少MM蜂拥而至,顿时万人空巷,连扫地的大妈都来凑热闹来了。―_―|||
由于人数太多,Wiskey实在忙不过来,就把统计的事情全交给了枫冰叶子,自己跑回家休息去了。这可够枫冰叶子忙的了,他要处理的有两类事情,一是得接受MM的报名,二是要帮Wiskey查找符合要求的MM中缘分最高值。
 


Input
本题有多个测试数据,第一个数字M,表示接下来有连续的M个操作,当M=0时处理中止。
接下来是一个操作符C。
当操作符为‘I’时,表示有一个MM报名,后面接着一个整数,H表示身高,两个浮点数,A表示活泼度,L表示缘分值。 (100<=H<=200, 0.0<=A,L<=100.0)
当操作符为‘Q’时,后面接着四个浮点数,H1,H2表示身高区间,A1,A2表示活泼度区间,输出符合身高和活泼度要求的MM中的缘分最高值。 (100<=H1,H2<=200, 0.0<=A1,A2<=100.0)
所有输入的浮点数,均只有一位小数。
 


Output
对于每一次询问操作,在一行里面输出缘分最高值,保留一位小数。
对查找不到的询问,输出-1。
 


Sample Input
8 I 160 50.5 60.0 I 165 30.0 80.5 I 166 10.0 50.0 I 170 80.5 77.5 Q 150 166 10.0 60.0 Q 166 177 10.0 50.0 I 166 40.0 99.9 Q 166 177 10.0 50.0 0
 


Sample Output
80.5 50.0 99.9



裸二维线段树。

有几个地方需要注意,查询可能x1 > x2, y1 > y2,还有更新的时候如果该位置已经有值 不是直接覆盖而是取max。

(还有一个地方我也没注意但是AC了,就是一开始不应该置0, 因为题目活了缘分值是可能为0的)


#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
using namespace std;

int T, h, N = 202, M = 1002, x1, x2, y1, y2, a;
double tmpa, ll, tmpy1, tmpy2;
char s[3];
double mx[222<<2][1111<<2];

void updatey(int o, int l, int r, int oo, int ok) {
    if(l == r) {
        if(ok == -1) mx[oo][o] = max(ll, mx[oo][o]); // 非直接覆盖,而是取最大值
        else mx[oo][o] = max(mx[oo<<1][o], mx[oo<<1|1][o]);
        return;
    }
    int m = (l+r) >> 1;
    if(a <= m) updatey(lson, oo, ok);
    else updatey(rson, oo, ok);
    mx[oo][o] = max(mx[oo][o<<1], mx[oo][o<<1|1]);
}

void updatex(int o, int l, int r) {
    if(l == r) {
        updatey(1, 1, M, o, -1);
        return;
    }
    int m = (l+r) >> 1;
    if(h <= m) updatex(lson);
    else updatex(rson);
    updatey(1, 1, M, o, 1);
}

double queryy(int o, int l, int r, int oo) {
    if(y1 <= l && r <= y2) return mx[oo][o];
    int m = (l+r) >> 1;
    double ans = -1.0;
    if(y1 <= m) ans = queryy(lson, oo);
    if(m < y2 ) ans = max(ans, queryy(rson, oo));
    return ans;
}

double queryx(int o, int l, int r) {
    if(x1 <= l && r <= x2) return queryy(1, 1, M, o);
    int m = (l+r) >> 1;
    double ans = -1.0;
    if(x1 <= m) ans = queryx(lson);
    if(m < x2 ) ans = max(ans, queryx(rson));
    return ans;
}

int main()
{
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d", &T) && T) {
        memset(mx, 0, sizeof(mx));
        while(T--) {
            scanf("%s", s);
            if(s[0] == 'I') {
                scanf("%d%lf%lf", &h, &tmpa, &ll);
                a = (int)(tmpa*10);
               // printf("(%d %d) -> %.1lf\n", h, a, ll);
                updatex(1, 1, N);
            } else {
                scanf("%d%d%lf%lf", &x1, &x2, &tmpy1, &tmpy2);
                y1 = (int)(tmpy1*10);
                y2 = (int)(tmpy2*10);

                if(x1 > x2) swap(x1, x2);
                if(y1 > y2) swap(y1, y2);  // 开始的时候忽略了。。

               // printf("x1 = %d , x2 = %d , y1 = %d , y2 = %d\n", x1, x2, y1, y2);
                double ans = queryx(1, 1, N);
                if(ans == 0) puts("-1");
                else printf("%.1lf\n", ans);
            }
        }
    }
    return 0;
}




HDU 1832 Luck and Love (二维线段树)

标签:des   style   blog   io   ar   os   sp   数据   div   

原文地址:http://blog.csdn.net/u013923947/article/details/40896135

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!