码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1502(Dijkstra)

时间:2014-11-07 22:08:38      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:dijkstra

MPI Maelstrom
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5538   Accepted: 3451

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee‘s research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,‘‘ Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.‘‘ 

``How is Apollo‘s port of the Message Passing Interface (MPI) working out?‘‘ Swigert asked. 

``Not so well,‘‘ Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.‘‘ 

``Is there anything you can do to fix that?‘‘ 

``Yes,‘‘ smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.‘‘ 

``Ah, so you can do the broadcast as a binary tree!‘‘ 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don‘t necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.‘‘

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35




解题思路:
	题意就是n台机器相互发送信息,要求从第一台机器,把剩下的n-1台都发送完所需的最小时间数。
	裸Dijkstra,用邻接矩阵存储。首先注意矩阵的初始化操作,主对角线赋值0,因为自己给自己发消息没意义,其他点设为无穷大。接下来比较奇葩的就是它的输入,它是按照下三角矩阵输入的,g[i][j] = g[j][i],对称的两个点权值相同。如果输入为x,那么代表i到j没有边,保持无穷大。
	下面上模板,最后在求出的dis数组里遍历,寻找最大值,那个就是我们所求的最短所需时间。(这里有点别扭,可以这么理解,dis[i]代表src源点到i的最短时间,既然n个点都要遍历,那么时间数一定要大于等于dis里的最大值才可以)
	最后,输入处理那看到有人直接用函数做的······我函数知道的少就直接模拟转换了····感觉自己萌萌哒····

完整代码:
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;

#pragma comment(linker, "/STACK:102400000,102400000")

typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;

/** Constant List .. **/ //{

const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
int n;
string s;
int g[201][201];
int dis[201];
bool vis[201];
int res;

void init()
{
    for(int i = 1 ; i <= n ; i ++)
    {
        for(int j = 1; j <= n ; j ++)
        {
            if(i == j)
                g[i][j] = 0;
            else
                g[i][j] = INF;
        }
    }
}

void dijkstra()
{
    for(int i = 1 ; i <= n ; i ++)
    {
        dis[i] = INF;
    }
    dis[1] = 0;
    memset(vis , 0 , sizeof(vis));
    for(int i = 1; i <= n ; i ++)
    {
        int mark = -1;
        int mindis = INF;
        for(int j = 1 ; j <= n ; j ++)
        {
            if(!vis[j] && dis[j] < mindis)
            {
                mindis = dis[j];
                mark = j;
            }
        }
        vis[mark] = 1;
        for(int j = 1 ; j <= n ; j ++)
        {
            if(!vis[j])
            {
                dis[j] = min(dis[j] , dis[mark] + g[mark][j]);
            }
        }

    }
    res = -INF;
    for(int k = 1 ; k <= n ; k ++)
    {
        if(dis[k] > res)
            res = dis[k];
    }
}

int main()
{
    #ifdef DoubleQ
    freopen("in.txt","r",stdin);
    #endif
    while(~scanf("%d",&n))
    {
        init();
        for(int i = 2 ; i <= n ; i ++)
        {
            for(int j = 1 ; j < i ; j ++)
            {
                cin >> s;
                if(s == "x")
                    continue;
                else
                {
                    int sum = 0;
                    int jin = 1;
                    int len = s.length();
                    for(int k = len - 1 ; k >= 0 ; k --)
                    {
                        if(k != len - 1)
                            jin *= 10;
                        sum += jin * (s[k] - '0');
                    }
                    g[i][j] = sum;
                    g[j][i] = sum;
                }
            }
        }
        dijkstra();
        cout << res << endl;
    }
}



















POJ1502(Dijkstra)

标签:dijkstra

原文地址:http://blog.csdn.net/u013447865/article/details/40898485

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!