码迷,mamicode.com
首页 > 编程语言 > 详细

pta c++ 两点间距离计算 (40分)

时间:2020-05-30 22:01:17      阅读:84      评论:0      收藏:0      [点我收藏+]

标签:distance   基本   protected   using   image   rom   mat   直接   坐标   

给出下面的一个基类框架:

class Point_1D

{ protected:

float x;//1D 点的x坐标

public:

Point_1D(float p = 0.0);

float distance(const Point_1D & p2);

}

以Point_1D为基类建立一个派生类Point_2D,增加一个保护数据成员:

float y;//2D平面上点的y坐标

以Point_2D为直接基类再建立一个派生类Point_3D,增加一个保护数据成员:

float z;//3D立体空间中点的z坐标

生成上述类并编写主函数,根据输入的点的基本信息,建立点对象,并能计算该点到原点的距离。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(点的类型(1表示1D点,2表示2D点,3表示3D点) 第一个点坐标信息(与点的类型相关) 第二个点坐标信息(与点的类型相关))。当读入0时输入结束,相应的结果不要输出。

输入样例:

1 -1 0

2 3 4 0 0

3 1 2 2 0 0 0

0

输出样例:

Distance from Point -1 to Point 0 is 1

Distance from Point(3,4) to Point(0,0) is 5

Distance from Point(3,3,3) to Point(0,0,0) is 3

#include <iostream>
#include<cmath>
using namespace std;

class Point_1D

{ 
protected:

    float x;//1D 点的x坐标

public:

    Point_1D(float x):x(x){
    }

    float distance(Point_1D b){
        return fabs(x-b.x);
    }

};
/* 请在这里填写答案 */
class Point_2D:public Point_1D{
protected:

    float y;

public:
    Point_2D(float x,float y):Point_1D(x),y(y){
    }
    
    float distance(Point_2D b){
        return sqrt(pow(x-b.x,2)+pow(y-b.y,2));
    }
};

class Point_3D:public Point_2D{
protected:

    float z;

public:
    Point_3D(float x,float y,float z):Point_2D(x,y),z(z){
    }
    
    float distance(Point_3D b){
        return sqrt(pow(x-b.x,2)+pow(y-b.y,2)+pow(z-b.z,2));
    }
};
int main( ) {
    int d=0;
    float x,y,z;
    float bx,by,bz;
    while(1){
        cin>>d;
        if(d==0)break;
        if(d==1){
            cin>>x;
            cin>>bx;
            Point_1D a(x);
            Point_1D b(bx);
            cout<<"Distance from Point "<<x<<" to Point "<<bx<<" is "<<a.distance(b)<<endl;
        }else if(d==2){
            cin>>x>>y;
            cin>>bx>>by;
            Point_2D a(x,y);
            Point_2D b(bx,by);
            cout<<"Distance from Point("<<x<<","<<y<<") to Point("<<bx<<","<<by<<") is "<<a.distance(b)<<endl;
        }else{
            cin>>x>>y>>z;
            cin>>bx>>by>>bz;
            Point_3D a(x,y,z);
            Point_3D b(bx,by,bz);
            cout<<"Distance from Point("<<x<<","<<y<<","<<z<<") to Point("<<bx<<","<<by<<","<<bz<<") is "<<a.distance(b)<<endl;
        }
    }
    return 0;
}

技术图片

 

pta c++ 两点间距离计算 (40分)

标签:distance   基本   protected   using   image   rom   mat   直接   坐标   

原文地址:https://www.cnblogs.com/xxw1/p/12995016.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!