码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3746 Cyclic Nacklace (KMP找循环节)

时间:2014-11-09 16:42:48      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   sp   

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:
bubuko.com,布布扣

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
3 aaa abca abcde
 

Sample Output
0 2 5
 


KMP算法找循环节:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
char str[100000+100];
int next[100000+100];
int n,len;
void get_next(char *s)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i!=len)
    {
        if(j==-1||s[i]==s[j])
            next[++i]=++j;
        else  j=next[j];
    }
}
int main()
{
     std::ios::sync_with_stdio(false);
     cin>>n;
     while(n--)
     {
         cin>>str;
         len=strlen(str);
         get_next(str);
        for(int i=0;i<=len;i++)
            cout<<"2333   "<<next[i]<<endl;
         int l=len-next[len];
         if(l!=len&&len%l==0)//l==len表示str不是循环的.
            cout<<0<<endl;
         else
            cout<<l-next[len]%l<<endl;
     }
     return 0;
}


HDU 3746 Cyclic Nacklace (KMP找循环节)

标签:des   style   blog   http   io   color   ar   os   sp   

原文地址:http://blog.csdn.net/u013582254/article/details/40950705

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!