码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2406 Power Strings

时间:2020-06-24 21:40:19      阅读:63      评论:0      收藏:0      [点我收藏+]

标签:time   put   pac   void   least   get   std   str   follow   

Time Limit: 3000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
【解析】
kmp算法 裸求最小循环节
【code】
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define N 1000009
char s[N];
int next[N];
int l;
void getnext()
{
    l=strlen(s);
    next[0]=-1;
    for(int i=1,j;i<l;i++)
    {
        j=next[i-1];
        while(s[i]!=s[j+1]&&j>=0)
        j=next[j];
        next[i]=s[i]==s[j+1]?j+1:-1;
    }
    if(l%(l-next[l-1]-1)==0)
    printf("%d\n",l/(l-next[l-1]-1));
    else
    printf("%d\n",-1);
}
int main()
{
    while(scanf("%s",s))
    {
        getnext();
    }
    return 0;
}

 

poj 2406 Power Strings

标签:time   put   pac   void   least   get   std   str   follow   

原文地址:https://www.cnblogs.com/zzyh/p/6853602.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!