码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3368 Frequent values(RMQ 求区间出现最多次数的数字的次数)

时间:2014-11-10 21:53:03      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:poj   rmq   st   

题目链接:http://poj.org/problem?id=3368


Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source


PS:

RMQ介绍+模板:http://blog.csdn.net/u012860063/article/details/40752197

代码如下:

#include <cstdio>
#include <cmath>
const int maxn = 100017;
int num[maxn], f[maxn], MAX[maxn][20];
int n;
int max(int a,int b)
{
    return a>b ? a:b;
}
int rmq_max(int l,int r)
{
    if(l > r)
        return 0;
    int k = log((double)(r-l+1))/log(2.0);
    return max(MAX[l][k],MAX[r-(1<<k)+1][k]);
}
void init()
{
    for(int i = 1; i <= n; i++)
    {
        MAX[i][0] = f[i];
    }
    int k = log((double)(n+1))/log(2.0);
    for(int i = 1; i <= k; i++)
    {
        for(int j = 1; j+(1<<i)-1 <= n; j++)
        {
            MAX[j][i] = max(MAX[j][i-1],MAX[j+(1<<(i-1))][i-1]);
        }
    }
}
int main()
{
    int a, b, q;
    while(scanf("%d",&n) && n)
    {
        scanf("%d",&q);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&num[i]);
            if(i == 1)
            {
                f[i] = 1;
                continue;
            }
            if(num[i] == num[i-1])
            {
                f[i] = f[i-1]+1;
            }
            else
            {
                f[i] = 1;
            }

        }
        
        init();
        
        for(int i = 1; i <= q; i++)
        {
            scanf("%d%d",&a,&b);
            int t = a;
            while(t<=b && num[t]==num[t-1])
            {
                t++;
            }
            int cnt = rmq_max(t,b);
            int ans = max(t-a,cnt);
            printf("%d\n",ans);
        }
    }
    return 0;
}


POJ 3368 Frequent values(RMQ 求区间出现最多次数的数字的次数)

标签:poj   rmq   st   

原文地址:http://blog.csdn.net/u012860063/article/details/40986561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!