码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3661 Runing

时间:2020-07-16 18:10:43      阅读:60      评论:0      收藏:0      [点我收藏+]

标签:body   esc   bsp   nta   table   div   accept   cto   distance   

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8597   Accepted: 3213

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her ‘exhaustion factor‘, which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie‘s exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

#include<iostream>
#include<cstring> 
#include<algorithm>
using namespace std;
int main()
{
    int n=0,m=0;
    cin>>n>>m;
    int* a=new int[n+1];
    int** f=new int*[n+1];
    for(int i=0;i<=n;i++)f[i]=new int[m+1];
    for(int i=1;i<=n;i++)cin>>a[i];
    for(int i=0;i<=n;i++)
        memset(f[i],0,sizeof(int)*(m+1));
    
    for(int i=1;i<=n;i++)
    {    
    f[i][0]=f[i-1][0];
        for(int j=1;j<=m&&j<=i;j++)
        {
            f[i][j]=f[i-1][j-1]+a[i];
            f[i][0]=f[i][0]>f[i-j][j]?f[i][0]:f[i-j][j];
        }
    }
    cout<<f[n][0];
}

 

POJ 3661 Runing

标签:body   esc   bsp   nta   table   div   accept   cto   distance   

原文地址:https://www.cnblogs.com/waiting-nobody/p/13323965.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!