码迷,mamicode.com
首页 > 其他好文 > 详细

1133 Splitting A Linked List (25分)

时间:2020-07-19 00:50:18      阅读:85      评论:0      收藏:0      [点我收藏+]

标签:describes   format   cal   elements   des   scan   pts   ica   Fix   

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (10?5??) which is the total number of nodes, and a positive K (10?3??). The address of a node is a 5-digit nonnegative integer, and NULL is represented by 1.

Then N lines follow, each describes a node in the format:

Address Data Next
 

where Address is the position of the node, Data is an integer in [10?5??,10?5??], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
 

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

#include<bits/stdc++.h>
using namespace std;
struct node{
    int add, dat, next;
};
node lt[100001];
vector<node> l,ans;
int main(){
    int beg, n, k;
    scanf("%d%d%d", &beg, &n, &k);
    for(int i=0;i<n;++i){
        int a, d, n;
        scanf("%d%d%d", &a, &d, &n);
        lt[a].add=a;
        lt[a].dat=d;
        lt[a].next=n;
    }
    for(int i=beg; i!=-1; i=lt[i].next)
        l.push_back(lt[i]);

    int len=l.size();
    for(int i=0; i<len; ++i)
        if(l[i].dat<0) ans.push_back(l[i]);
    for(int i=0; i<len; ++i)
        if(l[i].dat>=0 && l[i].dat<=k) ans.push_back(l[i]);
    for(int i=0; i<len; ++i)
        if(l[i].dat>k) ans.push_back(l[i]);
    for(int i=0;i<ans.size();++i){
        if(i!=ans.size()-1) printf("%05d %d %05d\n", ans[i].add, ans[i].dat, ans[i+1].add);
        else printf("%05d %d -1\n", ans[i].add, ans[i].dat);
    }
    return 0;
}

 

1133 Splitting A Linked List (25分)

标签:describes   format   cal   elements   des   scan   pts   ica   Fix   

原文地址:https://www.cnblogs.com/LS-Joze/p/13338191.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!