码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3187 Backward Digit Sums 【暴搜】

时间:2014-11-11 16:33:28      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:poj3187

Backward Digit Sums
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4487   Accepted: 2575

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ‘s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ‘s mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source

先把第一行每个位置要加的次数求出来,会发现是一个杨辉三角,将这个杨辉三角打成表,每次枚举第一行的组成情况,直接用这个表计算结果。

#include <stdio.h>
#include <string.h>
#include <algorithm>

int lev[12][12];
int box[12], N, S;

int main() {
    int i, j, sum;
    lev[1][1] = 1;
    for(i = 2; i <= 10; ++i)
        for(j = 1; j <= i; ++j)
            if(j == 1 || j == i) lev[i][j] = 1;
            else lev[i][j] = lev[i-1][j] + lev[i-1][j-1];
            
    while(scanf("%d%d", &N, &S) == 2) {
        for(i = 1; i <= N; ++i)
            box[i] = i;
        do {
            sum = 0;
            for(i = 1; i <= N; ++i)
                sum += box[i] * lev[N][i];
            if(sum == S) break;
        } while(std::next_permutation(box + 1, box + N + 1));

        for(i = 1; i <= N; ++i)
            printf("%d%c", box[i], i == N ? '\n' : ' ');
    }
    return 0;
}


POJ3187 Backward Digit Sums 【暴搜】

标签:poj3187

原文地址:http://blog.csdn.net/chang_mu/article/details/41012659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!