码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构之 线性表--链表的逆置

时间:2014-11-11 18:28:17      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   os   sp   for   数据   div   log   

数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <algorithm>

using namespace std;

struct node
{
    int data;
    struct node *next;
};

int main()
{
    int n;
    int len=0;

    struct node *head, *p;
    head=new struct node;
    head->next=NULL;

    while(cin>>n && n!=-1 )
    {
        p=new struct node;
        p->data = n;
        p->next = head->next;
        head->next=p;
        len++;
    }
    for(int i=1; i<=len; i++)
    {
        if(i==1)
        {
            cout<<head->next->data;
        }
        else
        {
            cout<<" "<<head->next->data;
        }
        head=head->next;
    }
    cout<<"\n";
    return 0;
}

 



数据结构之 线性表--链表的逆置

标签:des   blog   io   os   sp   for   数据   div   log   

原文地址:http://www.cnblogs.com/yspworld/p/4090051.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!