码迷,mamicode.com
首页 > 其他好文 > 详细

ACM题目 1083: Hello, world!

时间:2020-09-17 17:23:30      阅读:51      评论:0      收藏:0      [点我收藏+]

标签:sci   nbsp   character   sim   style   led   lines   tabs   eof   

题目描述:

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入:

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出:

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入:

72 101 108 108 111 44
32 119 111 114 108 100 33

样例输出:

Hello, world!

思路:

将所有数字存放到一个数组中

然后对数组中每一个数字取整数输出

代码:

#include<stdio.h>
int main()
{
    char c;
    int a[100],i=0;
    while((scanf("%d",&a[i]))!=EOF)
    {
        i++;
    }
    for(int j=0;j<i;j++)
        printf("%c",a[j]);
    return 0;
}

  

 

ACM题目 1083: Hello, world!

标签:sci   nbsp   character   sim   style   led   lines   tabs   eof   

原文地址:https://www.cnblogs.com/redzzy/p/13626907.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!