码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4648

时间:2014-05-18 04:56:14      阅读:317      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   hdu   多校联合   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4648

Magic Pen 6

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1857    Accepted Submission(s): 637


Problem Description
In HIT, many people have a magic pen. Lilu0355 has a magic pen, darkgt has a magic pen, discover has a magic pen. Recently, Timer also got a magic pen from seniors.

At the end of this term, teacher gives Timer a job to deliver the list of N students who fail the course to dean‘s office. Most of these students are Timer‘s friends, and Timer doesn‘t want to see them fail the course. So, Timer decides to use his magic pen to scratch out consecutive names as much as possible. However, teacher has already calculated the sum of all students‘ scores module M. Then in order not to let the teacher find anything strange, Timer should keep the sum of the rest of students‘ scores module M the same.

Plans can never keep pace with changes, Timer is too busy to do this job. Therefore, he turns to you. He needs you to program to "save" these students as much as possible.
 

Input
There are multiple test cases.
The first line of each case contains two integer N and M, (0< N <= 100000, 0 < M < 10000),then followed by a line consists of N integers a1,a2,...an (-100000000 <= a1,a2,...an <= 100000000) denoting the score of each student.(Strange score? Yes, in great HIT, everything is possible)
 

Output
For each test case, output the largest number of students you can scratch out.
 

Sample Input
2 3 1 6 3 3 2 3 6 2 5 1 3
 

Sample Output
1 2 0
Hint
The magic pen can be used only once to scratch out consecutive students.
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  4822 4821 4820 4819 4818 
 

简单题,len从大到小,(sum[j+len]-sum[j])%M==0 len即为所求。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAX=100010;
int sum[MAX];
int main()
{
    int N,M;
    while(cin>>N>>M)
    {
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=N;i++)
        {
            int x;
            scanf("%d",&x);
            sum[i]=sum[i-1]+x;
        }
        bool flag=true;
        for(int i=N;i>=0&&flag;i--)
        {
            for(int j=0;j+i<=N;j++)
            {
                if((sum[j+i]-sum[j])%M==0)
                {
                    cout<<i<<endl;
                    flag=false;
                    break;
                }
            }
        }
    }
    return 0;
}


hdu 4648,布布扣,bubuko.com

hdu 4648

标签:acm   算法   hdu   多校联合   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/26012873

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!