码迷,mamicode.com
首页 > 其他好文 > 详细

1024 Palindromic Number (25分)

时间:2021-02-01 12:26:52      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:isp   from   repeat   base   not   ever   clu   origin   written   

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3
 

Sample Output 1:

484
2
 

Sample Input 2:

69 3
 

Sample Output 2:

1353
3

题解:
大整数加法,用字符串
#include<bits/stdc++.h>
using namespace std;
const int maxn=10010;
string add(string m,string n) {
    int len=n.length();
    int carry=0;
    for(int i=0; i<len; i++) {
        m[i]= m[i] + n[i] + carry - 0;//注意正数与字符的运算
        carry=0;
        if(m[i]>9) {
            m[i]=m[i]-10;//注意正数与字符的运算
            carry=1;
        }
    }
    if(carry==1) {
        m+=1;
    }
    reverse(m.begin(),m.end());
    return m;

}
bool isP(string n) {
    int len=n.length();
    for(int i=0; i<=len/2; i++) {
        if(n[i]!=n[len-1-i]) {
            return false;
        }
    }
    return true;
}
int main() {
    string n,m;
    int k,cnt=0;
    cin>>n;
    cin>>k;
    int flog=0;
    for(int i=0; i<k; i++) {
        m=n;
        if(!isP(m)) {
            reverse(n.begin(),n.end());
            n=add(n,m);
            cnt++;
        } else {
            if(cnt<=k) {
                cout<<m<<endl;
                cout<<cnt<<endl;
                flog=1;
                break;
            }
        }
    }
    if(flog==0) {
        cout<<n<<endl;
        cout<<k<<endl;
    }
    return 0;
}

 

1024 Palindromic Number (25分)

标签:isp   from   repeat   base   not   ever   clu   origin   written   

原文地址:https://www.cnblogs.com/dreamzj/p/14351112.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!