码迷,mamicode.com
首页 > 其他好文 > 详细

Matrix Chain Multiplication UVA - 442

时间:2021-02-08 11:54:10      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:job   repr   ack   clu   letter   win   specified   NPU   sample   

Suppose you have to evaluate an expression like ABCDE where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 5010 matrix, B a 1020 matrix and C a 205 matrix. There are two different strategies to compute ABC, namely (AB)C and A(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n (1 ≤ n ≤ 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } < EOF>

Line = Expression < CR>

Expression = Matrix | "(" Expression Expression ")"

Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output

For each expression found in the second part of the input file, print one line containing the word ‘error’ if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

HINT

使用map来记录矩阵,使用栈来存入数组。思路很简单,直接看代码就好。

注意:每一次做乘法计数的时候偶要判断是不是字母,否则会出错!!!

Accepted

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<vector>
#include<stack>
#include<queue>
#include<set>
using namespace std;


int main()
{
	map<string, vector<int>>M;
	long long int sum = 0;
	int n,a,b;
	string t,s;
	cin >> n;
	while (n--) {
		cin >> t >> a >> b;
		M[t].push_back(a);
		M[t].push_back(b);
	}
    getchar();		//
	while (getline(cin, s)) {
		stack<int>list;
		sum = 0;
		if (s.length() == 1)cout << 0 << endl;
		else {
			for (int i = 0;i < s.length();i++) {
				if (s[i] == ‘(‘)continue;
				if (s[i] == ‘)‘) {	//计算
					b = list.top();list.pop();
					a = list.top();list.pop();
					if (a != list.top()) { cout << "error" << endl;sum = -1;break; }
					list.pop();
					sum += a * b * list.top();
					list.push(b);
				}
				else {				//入栈
					t = s[i];
					list.push(M[t][0]);
					list.push(M[t][1]);
				}
			}
			if (sum != -1)	cout << sum << endl;
		}
	}
}

Matrix Chain Multiplication UVA - 442

标签:job   repr   ack   clu   letter   win   specified   NPU   sample   

原文地址:https://www.cnblogs.com/3236676588buladuo/p/14382471.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!