码迷,mamicode.com
首页 > 其他好文 > 详细

Trees on the level UVA - 122

时间:2021-02-08 12:29:55      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:algorithm   init   break   out   iostream   describe   stream   map   back   

Trees are fundamental in many branches of computer science (Pun definitely intended). Current stateof-the art parallel computers such as Thinking Machines’ CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. This problem involves building and traversing binary trees.

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.
技术图片

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree on the right is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs ‘(n,s)’ where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of ‘L’s and ‘R’s where ‘L’ indicates a left branch and ‘R’ indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs ‘(n,s)’ as described above separated by whitespace. The last entry in each tree is ‘()’. No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ‘not complete’ should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

HINT

这个题目可以不适用二叉树,可以使用map排序来解决,但学到数据结构了就使用二叉树来解决的。

程序设计思路是每行进行读取,然后读取这一行中的内容,直到遇到()结束这一组数据。用指针数组来存储数据。只要遇到一组数据就插入到二叉树里面,如果二叉树对应的结点已经插入了数据,就输出错误,如果二叉树查找对应结点的时候遇到了中间还没有插入的结点,那么就先建立一个空的结点,存储的数据string num的大小为0,(不为0说明已经存入了数据)。输出采用的是层序遍历,当发现有结点的数据域的长度为0那么就说明这个点没有插入输出错误。

这个题目程序有很多细节需要注意,针对自己的程序的总结如下:

  1. 使用 new后一定要初始化结点。
  2. 每次输出结果都要将二叉树删除,并将头指针指空。
  3. 删除结点递归的时候一定要先判断左右孩子是否为空,先序遍历也一样。

Accepted

#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<sstream>

using namespace std;
struct TREE{
	string num;
	TREE* right;
	TREE* lift;
};

void remove(TREE* head){	//删除结点空间
	if (!head)return;
	if(head->lift)	remove(head->lift);
	if(head->right)	remove(head->right);
	delete(head);
}

bool insert(TREE* head, string var, string s) {	//插入
	TREE* p = head,*temp;
	for (int i = 0;i < s.size()-1;i++) {
		temp = s[i] == ‘R‘ ? p->right : p->lift;
		if (temp==NULL){
			temp = new TREE;		//如果是空的就申请空间
			temp->lift = temp->right = NULL;
		}
		if (s[i] == ‘R‘)p->right = temp;
		else p->lift = temp;
		p=temp;		//向下指
	}
	if (p->num.size())return 0;
	else { p->num = var;return 1; }
}

void print(TREE* head) {			//首先层序遍历,然后输出,以内要先判断是否合法
	vector<TREE *>list;				//因为不需要边输出边层序遍历,所以不用使用队列
	int i = 0;
	if(head) list.push_back(head);
	while (i++ < list.size()) {		//遍历
		if (!list[i-1]->num.size()) { cout << "not complete" << endl;return; }
		if (list[i-1]->lift)list.push_back(list[i-1]->lift);
		if (list[i-1]->right)list.push_back(list[i-1]->right);
	}
	for (int i = 0;i < list.size();i++) {	//输出
		if (i)cout << ‘ ‘ << list[i]->num;
		else cout << list[i]->num;
	}
	cout << endl;
}

using namespace std;
int main(){
	TREE* head=NULL;
	string s,svar;
	while(getline(cin,s)){		//读取每一行
		if (!head) {
			head = new TREE;	//申请头地址
			head->lift = head->right = NULL;
		}
		stringstream ss(s);
		while (ss >> s ) {		//读取每一个点
			if (s == "()") {	//清空并输出。
				print(head);
				remove(head);
				head = NULL;
				break;
			}
			int i = s.find(‘,‘);				//拆分
			svar = s.substr(1, i-1);			//数值位
			s = s.substr(i + 1, s.size()-1);//路径
			if (!insert(head, svar, s)) {
				cout << "not complete" << endl;
				remove(head);head = NULL;
				while (ss >> s)if (s == "()")break;//清空本组数据
				while (s != "()")cin >> s;		
				break;			//调出循环,进行下一组
			}	
		}
	}
}

Trees on the level UVA - 122

标签:algorithm   init   break   out   iostream   describe   stream   map   back   

原文地址:https://www.cnblogs.com/3236676588buladuo/p/14385627.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!