码迷,mamicode.com
首页 > 其他好文 > 详细

1002 A+B for Polynomials (25 分)

时间:2021-02-10 13:03:20      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:isp   can   ber   where   i++   sum   one   math   --   

This time, you are supposed to find \(A+B\) where \(A\) and \(B\) are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

\[K,N_1,a_{N_1},N_2,a_{N_2},\cdots,N_k,a_{N_k} \]

where K is the number of nonzero terms in the polynomial, \(N_i\)
?? and \(a_{?N_i}\)\((i=1,2,?,K)\) are the exponents and coefficients, respectively. It is given that \(1≤K≤10\)\(0≤N_K<?<N_2<N_1≤1000\).

Output Specification:

For each test case you should output the sum of \(A\) and \(B\) in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意

计算两个多项式相加的新多项式

思路

将a、b中系数不为0的项加入长度为最大值k的数组s并相加,输出s中值不为0的项。

代码

#include <cstdio>
int main(){
    int m,k,exp,sk=0;
    double s[1001]={0.0};
    double cff;
    for(int i=0;i<2;i++){
        scanf("%d",&k);
        for(int j=0;j<k;j++){
            scanf("%d%lf",&exp,&cff);
            s[exp]+=cff;
        }
    }
    for(int i=0;i<1001;i++){
        if(s[i]!=0.0){
            sk++;
        }
    }
    printf("%d",sk);
    for(int i=1000;i>-1;i--){
        if(s[i]!=0.0){
            printf(" %d %.1f",i,s[i]);
        }
    }
    return 0;
    }

1002 A+B for Polynomials (25 分)

标签:isp   can   ber   where   i++   sum   one   math   --   

原文地址:https://www.cnblogs.com/lululada/p/14393313.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!