码迷,mamicode.com
首页 > 其他好文 > 详细

1047 Student List for Course ——PAT甲级真题

时间:2021-02-17 14:09:06      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:ace   follow   inpu   git   push   this   ber   pre   输出   

1047 Student List for Course

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student‘s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students‘ names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意: 一共有N个学生和K门课,每门课的编号为1~K,给出每个学生的选课编号,让你求出编号为i的课有哪些学生选,并按照字典序输出这些学生的编号.

大致思路:利用vector<string>存储学生姓名,然后排序注意输出,注意如果用cout输出会超时,要改为 printf("%s\n", course[i][j].c_str()) .

代码:

#include <bits/stdc++.h>

using namespace std;

int n, k;

int main() {
    scanf("%d%d", &n, &k);
    vector<string> course[n];
    for (int i = 0; i < n; i++) {
        string name;
        int c;
        cin >> name;
        scanf("%d", &c);
        for (int j = 0; j < c; j++) {
            int d;
            scanf("%d", &d);
            course[d].push_back(name);
        }
    }
    for (int i = 1; i <= k; i++) {
        sort(course[i].begin(), course[i].end());
        printf("%d %d\n", i, course[i].size());
        for (int j = 0; j < course[i].size(); j++) printf("%s\n", course[i][j].c_str());
    }
    return 0;
}

1047 Student List for Course ——PAT甲级真题

标签:ace   follow   inpu   git   push   this   ber   pre   输出   

原文地址:https://www.cnblogs.com/gxsoar/p/14401294.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!