码迷,mamicode.com
首页 > 其他好文 > 详细

1090 Highest Price in Supply Chain (25 分)

时间:2021-02-24 13:16:47      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:dfs   std   const   ups   nbsp   col   reset   using   lang   

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence they are numbered from 0 to N?1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S?i?? is the index of the supplier for the i-th member. S?root?? for the root supplier is defined to be ?. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6
 

Sample Output:

1.85 2


#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define eps 1e-8
#define  inf  0x3fffffff
vector<vector<int> > v;
double maxde=0;
int maxnum=1;
double p,pr;
void dfs(int index,double p){
    if(v[index].size()==0){
        if(p>maxde){
            maxde=p;
            maxnum=1;
        }
        else if(abs(p-maxde)<eps){
            maxnum++;
        }
        return ;
    }
    for(int i=0;i<v[index].size();i++){
        dfs(v[index][i],p*(1+pr));
    }
}
int main(){
    int n;
    int root;
    scanf("%d",&n);
    scanf("%lf %lf",&p,&pr);
    pr=pr/100;
    v.resize(n);
    for(int i=0;i<n;i++){
        int temp;
        scanf("%d",&temp);
        if(temp==-1){
            root=i;
            continue;
        }
        v[temp].push_back(i);
    }
    dfs(root,p);
    printf("%.2f %d\n",maxde,maxnum);
    return 0;
}

 

1090 Highest Price in Supply Chain (25 分)

标签:dfs   std   const   ups   nbsp   col   reset   using   lang   

原文地址:https://www.cnblogs.com/dreamzj/p/14438675.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!