码迷,mamicode.com
首页 > 其他好文 > 详细

1106 Lowest Price in Supply Chain (25 分)

时间:2021-02-24 13:20:28      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:零售   ram   ota   scanf   sum   case   ext   put   print   

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N?1, and the root supplier‘s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K?i?? ID[1] ID[2] ... ID[K?i??]

where in the i-th line, K?i?? is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. K?j?? being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
 

Sample Output:

1.8362 2


#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define esp 1e-8
#define inf 0x3fffffff
int n;
double p,pr;
int cnt=1;
double minp=inf;
vector<vector<int> > v;
void dfs(int index,double p){
    if(v[index].size()==0){
        if(p<minp){
            cnt=1;
            minp=p;
        }
        else if(abs(p-minp)<esp){
            cnt++;
        }
        return ;
    }
    for(int i=0;i<v[index].size();i++){
        dfs(v[index][i],p*(1+pr));
    }
}
int main(){
    
    scanf("%d %lf %lf",&n,&p,&pr);
    pr=pr/100;
    v.resize(n);
    for(int i=0;i<n;i++){
        int k;
        scanf("%d",&k);
        if(k==0){
            continue;
        }
        for(int j=0;j<k;j++){
            int temp;
            scanf("%d",&temp);
            v[i].push_back(temp);
        }
    }
    dfs(0,p);
    printf("%.4f %d\n",minp,cnt);
    return 0;
}

 

1106 Lowest Price in Supply Chain (25 分)

标签:零售   ram   ota   scanf   sum   case   ext   put   print   

原文地址:https://www.cnblogs.com/dreamzj/p/14438975.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!