码迷,mamicode.com
首页 > 其他好文 > 详细

1121 Damn Single (25 分)

时间:2021-03-01 13:14:50      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:lang   tput   rri   dig   HERE   next   and   nio   for   

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID‘s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID‘s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID‘s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
 

Sample Output:

5
10000 23333 44444 55555 88888


#include<bits/stdc++.h>
using namespace std;
const int maxn=1000010;
map<int,int> mp;
set<int> s;

int main(){
    int n,k,a,b;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>a>>b;
        mp[a]=b;
        mp[b]=a;
    }
    cin>>k;
    int temp;
    for(int i=0;i<k;i++){
        cin>>temp;
        s.insert(temp);
    }
    vector<int> v;
    for(set<int>::iterator it=s.begin();it!=s.end();it++){
        if(s.find(mp[*it])==s.end()){
            v.push_back(*it);
        }
    }
    printf("%d\n",v.size());
    for(int i=0;i<v.size();i++){
        if(i<v.size()-1){
            printf("%05d ",v[i]);
        }
        else{
            printf("%05d\n",v[i]);
        }
    }
    return 0;
}

 

1121 Damn Single (25 分)

标签:lang   tput   rri   dig   HERE   next   and   nio   for   

原文地址:https://www.cnblogs.com/dreamzj/p/14457078.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!